• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

LrC 9.3 Import/Export *EX* Slow but LR 6.14 works fine? Hardware conflict?

Epoch

New Member
Joined
Sep 23, 2014
Messages
9
Location
Sri Lanka
Lightroom Experience
Advanced
Lightroom Version
Classic
Lightroom Version
Lightroom Classic Version 9.3
Operating System
  1. Windows 10
Hi guys!

Here's the issue:

LrC 9.3 will slow to a complete crawl 4 out of 5 times when Importing or Exporting.
Yet LR 6.14 will have zero problems importing/exporting the very same files on the same disks.


By slow I mean 5 1920x1920px jpegs can sometimes take upto 35 minutes to import.
At other times 64GB of D850 NEFs can take 30 minutes.
File type, size, location on SSD or SATA HDD makes no difference.
Other symptoms: The entire computer can lock up sometimes. Browser becomes unresponsive but audio from a YT vid in the background will continue to play sans stuttering.
If left for long enough (1 or two hours) LrC will complete the import/export with no problems.
This has been the case since I first installed LrC 1 year ago.
1 out of 5 times it will perform both actions seamlessly.
At other times the export will complete with the bar filling right to the end but LrC will be unresponsive, the files are exported but it hangs for some minutes.
Exports always complete.
Imports hang for much longer where I end up cancelling the task and restarting LrC until it works.
Imports via card reader generally complete faster than Sync Folder on local disk or import from local disk actions.
Restarting Windows can sometimes clear the problem temporarily.
Affects all catalogues (I have multiple).
Deleting the Preferences file makes no difference.

LR Cat and files are on SSDs with plenty of space for previews / caching.
PC: Win 10, i7 7700k @ 4.20-4.50ghz (no OC), 32GB RAM, GTX 1070.
All firmware & drivers are up-to-date.
No thermal issues although LrC power consumption is 'very high' when it chugs.

With LR 6.14 I have run multiple exports simultaneously to stress the CPU and it performs without an issue.

Before I reinstall the software I'm curious to know if anyone have any thoughts on where the issue might be given the contrast between the two versions?
Grateful for any input!
:)
 
Last edited:
Joined
Sep 29, 2007
Messages
22,967
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Are you still running more than one export at a time? There were some performance changes to make better use of the computer spec, doing more stuff in parallel automatically instead of needing to manually start multiple exports.
 

Epoch

New Member
Joined
Sep 23, 2014
Messages
9
Location
Sri Lanka
Lightroom Experience
Advanced
Lightroom Version
Classic
Thank you for your response Victoria!
I only ran the parallel exports in LR 6.14.
It wouldn't be possible in LrC as it really does seem to take greater advantage of the specs.

The issue however is that even a single Import (via disk rather than memory card) or export can stall and take an abnormal amount of time to clear.
Something is causing LrC to not play nice with the hardware that I'm guessing LR 6.14 doesn't seem to have a problem with.
 
Joined
Sep 29, 2007
Messages
22,967
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
That does sound frustrating. Reinstall would be a good place to start. Might also be worth testing a clean catalog to narrow it down a bit.
 

Epoch

New Member
Joined
Sep 23, 2014
Messages
9
Location
Sri Lanka
Lightroom Experience
Advanced
Lightroom Version
Classic
Thank you again for taking the time to reply.
I suppose I'm trying to work out whether it is a strange hardware conflict or the software itself. I'll reinstall and have a go!
 
Top