• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Freeze after publish in LR CC 6.6 (2015.6)

Marc Rochkind

Member
Joined
Jan 18, 2008
Messages
34
Publish works perfectly, and completes normally. But then LR freezes (spinning blue circle cursor) about 5 sec. later. 100% repeatable. Never a crash; only a freeze. (Therefore no crash log.)

Other than this, LR works perfectly for me, with no crashes or freezes.

Tried it with 4 different plugins: SmugMug from Jeffrey Friedl, SmugMug (the official one), and Alloy; and Flickr from Jeffrey Friedl.

Tried 3 different LR versions: 2015, 2015.5.1, 2015.6.

GPU both on and off.

Windows 10 system with all windows updates, and updated Intel drivers as well.

Freezes on export to SmugMug as well -- not only publish.

Tried rebooting and wiping preferences.

Tried it with a brand new catalog.

Googling around, it seems that a few people have reported the same problem. If anyone has an idea of what to try, I'd like to hear it. But, mostly, I'm looking to see if others can post here if they have something similar.

(I've seen several posts various places about freezing during import, and even an Adobe fix for this, but that's a different issue.)

I've been using LR since version 1, on a Mac. Switched to Windows about 6 months ago, but never used any of the export/plugins until a few days ago.
 

Marc Rochkind

Member
Joined
Jan 18, 2008
Messages
34
This morning I decided to try again to come up with something. In desperation, I looked at Victoria's "Standard Lightroom Troubleshooting Steps" (Standard Lightroom Troubleshooting Steps), and got through 7 of them:

1. The magic reboot -- NO HELP
2. Optimize the Catalog-- NO HELP
3. Check for Updates-- NO HELP
4. Reset Preferences-- NO HELP
5. Try a new catalog-- NO HELP
6. Rule out corrupted presets & fonts -- SKIPPED THIS ONE
7. Try a clean user account - -BINGO!

A clean user account meant that something in my user-specific settings was causing LR to hang. I renamed the folder:

C:\Users\[username]\AppData\Roaming\Adobe\Lightroom

to:

C:\Users\[username]\AppData\Roaming\Adobe\Lightroom-save

And published, without a subsequent freeze! Then I copied back the only presets I cared about, those for export.

All now appears to be well. If I have any other presets I want back, I can copy them into the live folder one-by-one, checking each time.

Still a LR bug, since nothing like this should cause a freeze, but at least I have gotten around the problem.

UPDATE: That was actually not the fix. When I launched LR from a newly-created user account, it did work, and I thought removing the AppData would do the trick, but it did not. Near as I can tell, however, it does work in the new user account, so maybe it's a registry problem. Anyway, I'm going to just move to that new user account, in the hopes that the problem then goes away for good.
 
Last edited by a moderator:
Joined
Feb 1, 2010
Messages
13,146
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Wow, thanks for reporting back, Marc.....I'm sure that'll be helpful to others. I'd been trying to come up with some suggestions, but didn't get anywhere close to it probably being a dodgy preset!
 

Marc Rochkind

Member
Joined
Jan 18, 2008
Messages
34
And now I've been working away in LR for over an hour, with lots of publishing intermixed with developing, and no crashes or freezes. This is with my new user account.
 
Top