• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Zoom ability bogs down with time

HMKell

HMKell
Joined
Mar 28, 2019
Messages
10
Location
Boulder, CO
Lightroom Experience
Intermediate
Lightroom Version
Classic
Lightroom Version
Lightroom Classic version 10.4
Operating System
  1. Windows 10
When I first start working on photos in Lightroom Classic, I am able to quickly zoom in to 100% no problem. But with time (15 minutes), zooming in bogs down and it can take 10-20 seconds for a 100% view to render. Everything else seems to work just fine, but the ability to zoom in is horribly affected.

Is there an explanation and/or does anyone know of any settings/preferences etc. that could help me out here? Thank you.

I use Windows10 and have an 8th gen i7 processor with 32GB RAM, 2TB Hard drive and a 512GB SSD
 
Joined
Apr 3, 2012
Messages
1,109
Lightroom Experience
Advanced
Lightroom Version
Classic

BobT

Active Member
Joined
Apr 7, 2009
Messages
232
Location
Australia
Lightroom Experience
Advanced
Lightroom Version
Classic
I have an old clunker of a computer and after making many edits at one sitting, it starts to slow down. It's easily fixed by exiting and reopening LR.
 

HMKell

HMKell
Joined
Mar 28, 2019
Messages
10
Location
Boulder, CO
Lightroom Experience
Intermediate
Lightroom Version
Classic
1. See if the issue is related to the graphics processor by temporarily setting Preferences > Performance > Use Graphics Processor to Off (or if it's already off, to Auto).

2. Do a clean uninstall/reinstall of the graphics driver following the instructions in step 3:
https://helpx.adobe.com/lightroom-classic/kb/troubleshoot-gpu.html#solution-4
Thanks for the reply - I did all of that and no improvement. Restarting my computer does help, but then the bog continues with time as before.
Do I need a new graphics processor?
 

HMKell

HMKell
Joined
Mar 28, 2019
Messages
10
Location
Boulder, CO
Lightroom Experience
Intermediate
Lightroom Version
Classic
Please do the menu command Help > System Info and copy/paste here the top lines down to the line "Installed Plugins:".
1633976741773.png

Thanks for any further help.
 
Joined
Apr 3, 2012
Messages
1,109
Lightroom Experience
Advanced
Lightroom Version
Classic
Do I need a new graphics processor?
That seems unlikely -- the GTX 1070 is a 5-year-old high-end GPU. Starting fast but slowly degrading in performance is much more likely a software issue, not a hardware issue.

One diagnostic: After LR starts bogging down greatly, copy and paste the lines starting with "Real memory" and "Virtual memory" from Help > System Info. If LR is using more and more memory, then that further indicates a software issue.
 

HMKell

HMKell
Joined
Mar 28, 2019
Messages
10
Location
Boulder, CO
Lightroom Experience
Intermediate
Lightroom Version
Classic
That seems unlikely -- the GTX 1070 is a 5-year-old high-end GPU. Starting fast but slowly degrading in performance is much more likely a software issue, not a hardware issue.

One diagnostic: After LR starts bogging down greatly, copy and paste the lines starting with "Real memory" and "Virtual memory" from Help > System Info. If LR is using more and more memory, then that further indicates a software issue.
1634072226483.png

Thanks again for your help.
 
Joined
Apr 3, 2012
Messages
1,109
Lightroom Experience
Advanced
Lightroom Version
Classic
Your LR's memory usage doesn't seem obviously out of line. Real memory used by LR increased from 1.7 GB in the first screen shoot to 6.8 GB in the second, and virtual memory used by LR increased from 8 GB to 14 GB. Real memory usage may be somewhat high for LR, but it's only 21% of your total real memory, so it may be related to the sluggishness, but I'm mildly skeptical it is. (When bugs in LR cause memory use to skyrocket, that can account for progressively worse sluggishness.)
 

HMKell

HMKell
Joined
Mar 28, 2019
Messages
10
Location
Boulder, CO
Lightroom Experience
Intermediate
Lightroom Version
Classic
Your LR's memory usage doesn't seem obviously out of line. Real memory used by LR increased from 1.7 GB in the first screen shoot to 6.8 GB in the second, and virtual memory used by LR increased from 8 GB to 14 GB. Real memory usage may be somewhat high for LR, but it's only 21% of your total real memory, so it may be related to the sluggishness, but I'm mildly skeptical it is. (When bugs in LR cause memory use to skyrocket, that can account for progressively worse sluggishness.)
If it is a software issue - what would you recommend?
Thx
 
Joined
Apr 3, 2012
Messages
1,109
Lightroom Experience
Advanced
Lightroom Version
Classic
I don't have anything concrete to recommend at this point. You'll find lots of low-probability suggestions out there, and it's certainly possible one would help. LR 11 will be out in a couple weeks, and definitely see if that helps; try a new graphics card, if you can afford it and can unload it if it doesn't help (likely).
 

HMKell

HMKell
Joined
Mar 28, 2019
Messages
10
Location
Boulder, CO
Lightroom Experience
Intermediate
Lightroom Version
Classic
I don't have anything concrete to recommend at this point. You'll find lots of low-probability suggestions out there, and it's certainly possible one would help. LR 11 will be out in a couple weeks, and definitely see if that helps; try a new graphics card, if you can afford it and can unload it if it doesn't help (likely).
OK - I'll keep trying - thanks for your input and help.
 

HMKell

HMKell
Joined
Mar 28, 2019
Messages
10
Location
Boulder, CO
Lightroom Experience
Intermediate
Lightroom Version
Classic
Hi again, John.
My LR started bogging down again so I thought I would send the system info to you again to see if you can pinpoint anything new.
1635784497116.png

Thanks again for any input.
Hale
 
Joined
Apr 3, 2012
Messages
1,109
Lightroom Experience
Advanced
Lightroom Version
Classic
Nothing stands out as unusual in terms of memory usage.

However, I noticed that you have driver version 30.0.14.7217, a recent Nvidia Game Ready driver. You might try doing a clean uninstall and then installing the most recent Studio driver. Nvidia's marketing bs doesn't clearly explain the difference, but there is this post by an employee explaining that Studio drivers are intended for creative apps like LR and are more stable.
 
Top