• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The August 2019 Lightroom updates are now available. Lightroom Classic includes advanced GPU support, batch HDR/pano merge and more. Lightroom (cloud-based service) has deleted photos on the desktop/mobile apps, as well as video support and batch metadata editing on Android. The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Yet Another Sync Problem!!!! YIKES!!

Joined
Apr 26, 2018
Messages
7
Location
Ohio, USA
Lightroom Experience
Intermediate
Lightroom Version
Classic 8
Lightroom Version
8.4
Operating System
macOS 10.14 Mojave, iOS
Hello All,

Boy, I really hate to post this but I am at a standstill after trying all options, and I still cannot solve my sync issue after over a week.

Background:
I have the 1TB LR plan and do most of my organization and asset management in Classic, and use Cloudy to do sharing, viewing, culling, and (more and more) editing.

I was on a trip for about 10 days and loaded up my classic catalog on an external SSD drive, and took it with me (I know there will be comments about that, but that’s not the point of this post). While on my trip I took about 8000 images so averaged about 800 a day. I started importing the photos via iPad Cloudy, but Internet was spotty, and I needed Classic’s assets tools, so I switched to importing to Classic.

When I got home, the catalog went back to his usual spot on my main hard drive, and all was going well. The cloud photos came into Classic, and the photos that were in Classic went to the cloud. Now, I did get that warning when I first opened the catalog that is was not being recognized as the syncing catalog, but I made it so, and all seemed to go well.

Over the next few days, I upgraded to Classic 8.4, and at that same time I did a large amount of folder moving in Classic ( I had photos over several drives and wanted to consolidate all to my new SSD drive), and this apparently seemed to drive up the syncing number oddly enough.

Shortly after I noticed sync issues. I had a several hour period in Classic where I was making many Collections and lots of edits, and started noticing my SYNC status swell. None of these collections or edits were showing up on the Cloud side.

So I waited. I thought maybe I just need to give it several days to do it’s under the hood job. 3 days later and nothing. It was stuck at syncing at 66,000 photos. The sync dialog windows has the famous and ominous “preparing to sync” and is otherwise blank showing no upward or downward activity.

So, I read the forums and did the following:
—searched for missing photos, and corrected a few
—cleared out a few sync errors on LR web
—deleted and re-installed LR 8.4 on desktop
—deleted an re-installed iPhone and iPad apps
—reset the sync data by selecting the OPTION key in the sync status
—went to Caches (on a Mac) and deleted the LRsync file (I did that daily for 3 days)

And nothing has changed. After deleting the LRsync file, it seems to quickly climb down from 120,000 but still gets stuck at around 66,000 (but never exactly the same number)

This screenshot shows the current status. I am not clear why the numbers do not match up

This morning I did some sync tests and all the Cloud apps sync just fine amongst themselves. But somehow Classic is not syncing with them at all, not even downloading the new pictures I added in Cloudy this morning.

Anyway, at this point, I am wondering if my only option is deleting all sync data? And what does this functionally do? Does it erase the whole cloud photo storage? Does it mean I have to start afresh?

Any advice is very appreciated! THANKS!
 

Attachments

Mark Hunter

New Member
Joined
Oct 20, 2017
Messages
6
Lightroom Experience
Advanced
Lightroom Version
Classic 8
I would suggest rolling back from LR Classic 8.4 to 8.3.1 That appeared to solve my Sync problems (albeit I am not on the Cloud Plan using LR Classic on two machines and just using sync to alow me to use LR mobile and creative cloud apps on my iphone and ipad). Rolling back is quick and easy and I don't think you have much to lose - it worked in my case.
 
Joined
Nov 5, 2017
Messages
258
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic 8
Joined
Jun 20, 2009
Messages
14,565
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Classic 8
...Now, I did get that warning when I first opened the catalog that is was not being recognized as the syncing catalog, but I made it so, and all seemed to go well.
When you change syncing catalogs, all of the images in the old sync catalog need to be removed from the cloud and images in synced collections in the new classic catalog will be uploaded to the cloud even though these might be the same images, the classic catalog file is different. This could explain the slow syncing as you might be replacing thousands(?) of cloud images with the local counterparts from the new sync catalog.


Sent from my iPad using Tapatalk
 
Joined
Apr 26, 2018
Messages
7
Location
Ohio, USA
Lightroom Experience
Intermediate
Lightroom Version
Classic 8
Update: I rolled back to 8.3 and this did not fix the problem. Since I had spent a week on resolving this to no avail, I made the nuclear decision to delete all sync data and start again.

I agree with clee01 that chaging the sync catalog may be the culprit.

Any other thoughts from anyone on how to avoid this in future?
 
Joined
Sep 29, 2007
Messages
21,505
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
How to avoid it? Trying to sync Classic with Cloudy is messy, so I'm not convinced it'll ever be completely avoidable. But, as far as moving catalogs to a different computer goes, if you literally pick up the catalog and move that to the external drive (no catalog backups, no export as catalog, literally just move it) and you also copy the Sync.lrdata file to the new computer, then it doesn't need to resync everything. That's the cleanest way of getting Classic working on a second computer.
 
Top