• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! There's new Presets in all versions, Super Resolution on the desktop, new Sharing options and more. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Library module Wrong Photo counts in metadata filter

Joined
Jun 7, 2018
Messages
10
Location
Germany
Lightroom Experience
Intermediate
Lightroom Version
Classic
Lightroom Version
10.2
Operating System
  1. macOS 11.0 Big Sur
Hi Forum!

I have a problem with the coount of photos within the metadata filter of the library module.

Having a look at "All Photographs": I've noticed that the count within the "Smart Preview Status" is wrong. Count says 130 Photos have smart preview. Selecting this, it shows 14063 photos in the grid (see All_Photographs.jpg).

I have two locations for my originals ("archive" and "original"). The count in the "original" folder is fine (except the smart preview status, see Folder_original.jpg), but the "archive" folder shows 1 Photo less within the metadata filters and the grid (13313 vs. 13312).

I've tried already the "Test integrity of this catalog" at Lightroom start, but this didn't fix the issue.

Is there a way to have Lightroom to recount these numbers?

Thanks,
Frank
 

Attachments

  • All_Photographs.jpg
    All_Photographs.jpg
    731.5 KB · Views: 21
  • Folder_archive.jpg
    Folder_archive.jpg
    712.3 KB · Views: 19
  • Folder_original.jpg
    Folder_original.jpg
    673.3 KB · Views: 19
Joined
Apr 3, 2012
Messages
873
Lightroom Experience
Advanced
Lightroom Version
Classic
I just filed a bug about the counts:

Please click Like and Follow below the first post in that bug report, which will make it a little more likely Adobe will prioritize a fix, and you'll be notified when its status changes.

I couldn't find any way to get them to display correctly. However, selecting the line Has Smart Preview in the Smart Preview Status column always displays all the photos with smart previews, and the count above the filmstrip is correct (e.g. 14063 of 14105 photos in your first screenshot). So the workaround is to ignore the count in the Smart Preview Status column and use the one just above the filmstrip.

Alternatively, if you're looking at All Photographs (and not a folder or collection), you can use a smart collection with Has Smart Preview Is True, which always shows the correct counts.
 
Joined
Apr 3, 2012
Messages
873
Lightroom Experience
Advanced
Lightroom Version
Classic
but the "archive" folder shows 1 Photo less within the metadata filters and the grid (13313 vs. 13312).
There could be a stack of two photos in that folder that is collapsed. (The Filter bar only operates on photos that are visible in grid view.) Select All Photographs and do Photo > Stacking > Expand All Stacks, then apply the filter.
 
Joined
Jun 7, 2018
Messages
10
Location
Germany
Lightroom Experience
Intermediate
Lightroom Version
Classic
Hi John,

I just liked/followed the bug report.
Concerning total Photo count: I really have two stacked photos - never realized that collapsing the stack reduces the count, but when I think about it, it's logical.

Many thanks for the hints!
Frank
 
Joined
Feb 1, 2010
Messages
12,951
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Could this have anything to do with the Smart Previews created behind the scenes for Syncing with the cloud being counted in one place and not in another? Just a thought.
No, it's definitely a bug. I can reproduce the issue in any of my catalogs (the one that syncs and all the others that don't). In fact the issue was reported to Adobe on a closed forum a few weeks before John reported it on the official public Adobe feedback site, so hopefully the two separate reports will lead to a speedy fix.
 
Top