• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

We can’t verify your subscription status. - Anyone suddenly got this problem?

Joined
Aug 8, 2019
Messages
5
Lightroom Version
Lightroom Classic
Operating System
  1. macOS 10.14 Mojave
I have had this problem for a week, and do not know why.

My subscription is valid and I can log onto Creative Cloud etc, but in Lightroom which is my principle programme, sometimes I can and sometimes I can't ? ! ? !
And sometimes it kicks me out after a few hours ? ! ? !

The only operating system (Mojave) issue I am aware of is my keychain login gets deleted when I try to circumvent the LR login...eg Log out of CC then back in.

I cannot be certain when it started, either when the latest LR was downloaded or when the clocks changed here in the UK.

Either way, as a longterm Lightroom and Mac user I am baffled, as I usually manage to sort things out.

Is anyone else having this problem, or suggestions as to cause, which either could be a Lightroom CC problem or an Apple problem, or both.
 
Joined
Aug 8, 2019
Messages
5
I am now starting to suspect my Mac OS is the cause of the problem, as when the time change happened it defaulted my iCloud setting to California time....not the computer time, that is still British Summer time.....and the iCloud settings, will contain my keychain access, which might have some mystical code that allows me to subscribe in to Lightroom.
Interesting problem, please share if this is happening to you..
 
Joined
Aug 8, 2019
Messages
5
My problems does not appear to be Adobe/Lightroom related, so this thread can end. I came to that conclusion as no one else was having this problem, but it sometimes occurs in other circumstances on my Mac operating system. Whatever caused it, was probably related to the roll over to British Summer Time.
I will investigate further an add anything relevant to Lightroom users, but it was likely caused by iCloud.
One important point though is that I was not aware that access to my Adobe subscription was controlled by Apple and its software performance.
I still only have intermittent access to Lightroom.
 
Joined
Mar 21, 2015
Messages
1,307
Location
Dublin, Ireland.
Lightroom Experience
Power User
Lightroom Version
I have seen some very odd (and frustrating behaviour) in relation to dates and times. Networks are particularly sensitive to different devices having different dates or times.

Some of the causes include...
1. Date /Time of the computer are not correct (maybe caused by a Summer Time issue).
2. Date/Time on a router was incorrect.
3. Maybe a combination of 1 or 2 but needed the browser cache to be cleared before a connection to a particular website could be established.
 
Joined
Aug 8, 2019
Messages
5
To complete this thread for future reference. I have eliminated the problem by removing Adobe Creative Cloud software from the start up menu, so it is no longer part of the log in file that sync with iCloud, which is still out of sync in some aspects.
To be clear, no further problems with Lightroom.
 
Top