• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Vs9- When Cropping a Photo the 2nd Monitor Function is Slow to Update?

dload88

New Member
Joined
Nov 7, 2019
Messages
3
Location
Texas, USA
Lightroom Experience
Advanced
Lightroom Version
Classic
Lightroom Version
9.0
Operating System
Windows 10
Lightroom has always been very responsive but I notice with Lightroom 9.0 the 2nd monitor is slow to update if at all when I crop an image?
Does anyone else have this issue?
Thanks

Machine Specs:
Win10 64bit | ASUS X99-AII | i7 6850K @ 3.60GHz | 32GB Ram | GeForce GTX 1080
 
Joined
Sep 29, 2007
Messages
22,466
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Interesting, I've heard a couple of other people say they're having issues with crop on 9.0, but I hadn't thought to ask if they had the 2nd monitor open. Is it normal with it closed?
 
Joined
Jun 20, 2009
Messages
15,885
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Classic
Interesting, I've heard a couple of other people say they're having issues with crop on 9.0, but I hadn't thought to ask if they had the 2nd monitor open. Is it normal with it closed?
I wonder if it is related to Windows and not MacOS.



Sent from my iPad using Tapatalk
 
Joined
Sep 29, 2007
Messages
22,466
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Yes, all of the reports I've seen are Windows. I'm suspecting it might even be a specific driver or related drivers.

So far I can see a Nvidia GTX 1050 (26.21.14.4112), NVIDIA GeForce GTX 1060 6GB (23.21.13.9125) and now this GTX 1080 too.
 
Joined
Sep 29, 2007
Messages
22,466
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service

dload88

New Member
Joined
Nov 7, 2019
Messages
3
Location
Texas, USA
Lightroom Experience
Advanced
Lightroom Version
Classic
Thank you for all the replies.
For what it's worth I updated GTX drivers to 441.12. It did not make any difference. The second monitor is still slow to update when cropping.
My primary monitor works fine. All controls are responsive. Everything is great except for the crop update on the second monitor.
I'll try your fix Victoria.
Thank you again.
 

dload88

New Member
Joined
Nov 7, 2019
Messages
3
Location
Texas, USA
Lightroom Experience
Advanced
Lightroom Version
Classic
I went back to version 8.4.1. Everything works great!
 
Joined
Sep 29, 2007
Messages
22,466
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
That's down to the extra processing being done with the post-crop vignette showing while cropping then I think. The second monitor isn't as optimized. In that bug report I linked to, there's a comment from Simon with a way to carry on using 9.0 with that new change disabled.
 
Top