Trouble Migrating Catalog and Images to New Hard Drive

Joined
May 13, 2009
Messages
64
Location
Arizona, USA
Lightroom Experience
Intermediate
Lightroom Version
Classic 7
#1
Lightroom Version
Lightroom Classic version: 8.0 [ 1193777 ]
Operating System
macOS 10.12 Sierra
I am at the dreaded point where I have to migrate my Lightroom Catalog and image files to a new, larger external hard drive.

I have used Finder to copy my Lightroom Catalog folder to the new drive. The catalog and preview files are there.

I have used the Folders panel in Lightroom to move image files to the new location. I would click, drag, and drop the folders at the new location in the Lightroom Folders panel. This process took two days.

Now, I am trying to open Lightroom (Classic) and navigate to the lightroom catalog on the new drive in the Folders Panel. But the new drive is not there. It WAS there when I was moving image file folders.

I have used Finder to verify that the new drive is mounted on the desktop (it is), that the Lightroom Library Folder is there with catalog and preview files (it is), and that the image files are there (they are, all 5TB of them). The old external hard drives have been ejected, powered down, and removed.

Would appreciate any ideas as to how I can get my new external hard drive with catalog file, preview files, and all image files to show up in the Lightroom Library Module Folders panel.

Thanks
 

Jim Wilde

Lightroom Guru
Staff member
Moderator
Lightroom Guru
Joined
Feb 1, 2010
Messages
11,103
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic 7
#2
Now, I am trying to open Lightroom (Classic) and navigate to the lightroom catalog on the new drive in the Folders Panel. But the new drive is not there. It WAS there when I was moving image file folders.
I'm not following you here. What was the sequence of events? Using Lightroom to move the images to the new drive, and with the intention also to move the catalog to the same new drive, the sequence should have been:

1. Move all the folders and images to the new drive using the catalog on the existing drive.
2. Close Lightroom and then copy the catalog folder to the new drive.
3. Then open Lightroom as normal (which will still use the old catalog), then in Lightroom do File>Open Catalog which opens a browser window which you use to navigate to the copy of the catalog on the new drive. Select it and you're done.
4. Check your Preferences>General Tab to make sure that Lightroom is set to open the new version of the catalog on the new drive.

Did your sequence match the above? If not, how did it differ?
 

JohanElzenga

Lightroom Guru
Staff member
Moderator
Lightroom Guru
Joined
Jul 2, 2015
Messages
7,929
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Classic 7
#3
I have used Finder to copy my Lightroom Catalog folder to the new drive. The catalog and preview files are there.

I have used the Folders panel in Lightroom to move image files to the new location. I would click, drag, and drop the folders at the new location in the Lightroom Folders panel. This process took two days.

Now, I am trying to open Lightroom (Classic) and navigate to the lightroom catalog on the new drive in the Folders Panel. But the new drive is not there. It WAS there when I was moving image file folders
Sounds like maybe you copied the catalog folder to the new drive first, and then started Lightroom (not realising it would still be using the old catalog) to move the image folders. In that case the catalog on the new drive is a copy from before you moved the photos. If you start Lightroom with that new catalog, it will not show what you did with the images after it was copied to the new drive, because you did that work while in the original catalog.
 

Jim Wilde

Lightroom Guru
Staff member
Moderator
Lightroom Guru
Joined
Feb 1, 2010
Messages
11,103
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic 7
#4
Sounds like maybe you copied the catalog folder to the new drive first, and then started Lightroom (not realising it would still be using the old catalog) to move the image folders. In that case the catalog on the new drive is a copy from before you moved the photos. If you start Lightroom with that new catalog, it will not show what you did with the images after it was copied to the new drive, because you did that work while in the original catalog.
Indeed, that was my thought also, though it wasn't completely clear, and which is why I wanted to check the sequence. If that was the case, simply recopying the catalog again should fix it.
 
Joined
May 13, 2009
Messages
64
Location
Arizona, USA
Lightroom Experience
Intermediate
Lightroom Version
Classic 7
#5
Thank you Johan and Jim for the very helpful replies. I did need to recopy the library file to the new hard drive. Things then worked fine. One of the problems was that until I did the initial copy of the library file to the new hard drive, the new drive did not show up in the Lightroom Library Mode folder panel. It seems that an image must be imported into Lightroom before that image's parent drive will show up in the folder panel. That's something I think Adobe could simplify.
Again, thanks for your excellent help.
 
Top