• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! Color Grading and improved zoom across the whole Lightroom family, plus graphical watermarks for the cloud-based Lightroom apps, as well as the usual new cameras, lens profiles and bug fixes. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

That syncing feeling ...

Joined
Dec 3, 2016
Messages
244
Location
Milton Keynes, UK
Lightroom Experience
Beginner
Lightroom Version
Lightroom Version
8.0
Operating System
Windows 10
I have what looks like 2 different syncing issues. It may be related to a recent move to a new PC but I am not sure. I use Lightroom Classic CC and sync some collections to the web. I do not use Lightroom CC although I have it installed on my PC. I have just returned from a trip to Berlin where I used the Lightroom CC camera on my iPhone 8 and this has highlighted the problems. Here goes:

1. I took 24 photos in Berlin using Lightroom CC on my phone. These have synced down to Lightroom CC on my iPad & PC but 25 (not 24) photos are shown as Pending under Sync Activity in Classic CC and have appeared so for 3 days. I have tried opening and closing LR and turning sync off and on but they are not syncing.

2. Viewing Sync Activity also shows 50 uploading errors but on checking a random sample these seems to be a mix of images which have synced ok and others which are in collections which should not be synced. Has something got corrupted?

Many thanks for your thoughts.
 
Joined
Feb 1, 2010
Messages
12,608
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
If I manually download and add the images to my LR_Mobile_pics folder will that make things worse?
Probably, so I wouldn't do that.

It sounds as though you have something that's stuck during syncing....looking at the sync activity is there anything in an error state, rather than just "pending"?

You could always try resetting the sync data file (go to Preferences>Lightroom Sync tab then hold down the Alt key and you should see a "Rebuild Sync Data" button appear).....clicking on that button might work to get things going again.
 
Joined
Dec 3, 2016
Messages
244
Location
Milton Keynes, UK
Lightroom Experience
Beginner
Lightroom Version
Hi Jim,
Thanks for your reply all the uploads are showing in error. All the iPhone downloads are showing as pending. I can't see a Rebuild Sync button, only a Delete All Syned Data which I'm not sure is what I want to do. Here's a screen shot.

Regards, Steve
no-sync.jpg
 
Joined
Feb 1, 2010
Messages
12,608
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Looking again at your screenshot, there's a scroll bar in the bottom half.....if you scroll all the way down, the Rebuild Sync Data button may appear at the end of the list, when you have the Alt key pressed.
 
Joined
Feb 1, 2010
Messages
12,608
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Did you restart after doing the rebuild?

If you still have the same issue, you may need to think about tracking down those files showing an error. If you click on the first one, I think you'll be taken to it in the Library Grid, it'll probably have the three dots showing it's trying to sync, so then you need to investigate to see if you can figure out why. Is the file missing? Is it too big, i.e. greater than 200mb in size? If not either of those, clicking on the three dots will often force a retry of the sync.
 
Joined
Dec 3, 2016
Messages
244
Location
Milton Keynes, UK
Lightroom Experience
Beginner
Lightroom Version
Hi Jim,
As mentioned in my original post, the 50 images with an error are either synced ok or should not be synced at all. In the case of the first file showing an error, if I click on it and go to the grid view, it's not in any collection and shouldn't be trying to sync. There are no three dots to click on - presumably they'd be on the thumbnail in the grid? The second image is in a collection and has synced so, again, shouldn't be trying to sync .
Unless the events are connected, for now I'd rather get the 25 images synced down than the 50 synced up as it's stopping me working on them! All very strange?
Cheers,
Steve
 
Joined
Feb 1, 2010
Messages
12,608
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Steve, I'm not sure I can help much further with this, I would have expected the Rebuild Sync Data to have cleared up those 50 images that seem to be stuck. On my own system I'd probably be examining each one individually and taking whatever action I felt was appropriate to clear the blockage. Generally that would be by removing them from syncing (i,e. by removing from All Synced Photographs), which should at least remove them from the Sync Activity process. If that worked I'd wait until syncing was up-to-date, then I'd try re-syncing those of the 50 that I wanted to sync, monitoring each one. In extreme situations I would perhaps Ctrl+S on them, then delete them from the Classic catalog in order to clear the blockage, then reimport them (either into Classic or LRCC, depending on whether I wanted originals or smart previews in the cloud).

Have you looked at the LRCC Web interface, to see if there are any pointers there (such as Sync Errors being reported)?

Alternatively, post at the official Adobe feedback site, hopefully one of the engineers will investigate to see if they can figure out what's happening, and fix it.
 
Joined
Dec 3, 2016
Messages
244
Location
Milton Keynes, UK
Lightroom Experience
Beginner
Lightroom Version
Thanks for your reply Jim, sorry I didn't spot it and don't seem to be getting the email alerts anymore. I will try what you suggest (ie remove them one at a time) although the 50 images are not technically stuck as they are either happily synced or shouldn't be synced in the first place!
Strangely, after an automatic Windows update yesterday (which I though I had turned off!) Lightroom gave me a /users permissions error which I thought might explain things but as far as I can see all necessary folders have write access.
I have now succumbed to impatience and have downloaded the 24 dngs from my phone and imported them. I am hoping I can clear up any resultant mess!
 
Top