• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Are you using the cloud-based Lightroom apps for Windows, Mac, iOS, Android and Web? Then you'll love my new book, Adobe Lightroom - Edit Like a Pro!

    You'll learn how to use the Lightroom cloud ecosystem to organize, edit and share your photos. You'll also come to understand the thought processes used by professional photographers when they're editing their own photos, so you can transform your photos quickly and easily. And better still, the eBooks are updated for every release, so it's always up to date.
  • 18 October 2022 It's Lightroom update time again and there's a new AI-based Masking tools and a new Content-Aware Remove Healing tool, as well as smaller features, new cameras, lenses and bug fixes! See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

text fields search by LR Web

Joined
Oct 28, 2015
Messages
72
Lightroom Experience
Advanced
Lightroom Version
Classic
Lightroom Version
12.0.1
Operating System
  1. Windows 10
I've looked but been unable to find the answer to this.

When using LR Web and searching, which text fields are searched?

My experience so far is that keywords are not searched (puzzles me why not) and User Comment field is not searched.

Title and caption field are searched.

Thanks.
 
Joined
Oct 28, 2015
Messages
72
Lightroom Experience
Advanced
Lightroom Version
Classic
I've looked but been unable to find the answer to this.

When using LR Web and searching, which text fields are searched?

My experience so far is that keywords are not searched (puzzles me why not) and User Comment field is not searched.

Title and caption field are searched.

Thank

if geotagged or these fields are otherwise populated, these are searched: Sublocation, City, State.

Country/Region is not (another mystery).

ISO country code is not.

Thanks.
 
Joined
Feb 1, 2010
Messages
13,836
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic
I've just tried using LrWeb to search on a specific keyword (i.e. something that doesn't appear anywhere else in any other field) and it found all the images that I'd added that keyword to. So the question is: how have you got your keywords to the cloud (given that they don't sync between LrC and the cloud)?

It also finds Country, so the same question arises.

It doesn't find Country Code, presumably because that isn't exposed in any of the cloud apps.
 
Joined
Oct 28, 2015
Messages
72
Lightroom Experience
Advanced
Lightroom Version
Classic
I've just tried using LrWeb to search on a specific keyword (i.e. something that doesn't appear anywhere else in any other field) and it found all the images that I'd added that keyword to. So the question is: how have you got your keywords to the cloud (given that they don't sync between LrC and the cloud)?

It also finds Country, so the same question arises.

It doesn't find Country Code, presumably because that isn't exposed in any of the cloud apps.
I created a collection in LR Classic and photos get synced to Web. I'm not doing anything else.

I see the keyword when I click on the tag icon on the LR Web page but if I search on the same keyword I get no hits.

I changed the Country code for one photo to something unique, then added it to the collection. Search doesn't find it.
 
Joined
Feb 1, 2010
Messages
13,836
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic
I created a collection in LR Classic and photos get synced to Web. I'm not doing anything else.

I see the keyword when I click on the tag icon on the LR Web page but if I search on the same keyword I get no hits.

I changed the Country code for one photo to something unique, then added it to the collection. Search doesn't find it.
When you create and sync a collection in LrC, any keywords are not automatically synced unless you happened to have saved metadata to XMP beforehand. But having said that, if you can see the keyword in LrWeb then it should find that when you search for it. So I don't qiuite know why it's not happening.

Country Code, like all the other location fields, do not sync to the cloud unless it was stored in XMP before the initial sync. So adding/changing it after sync will not have any visibility in the cloud, and as I said it also seems that it's not stored even if you had it stored in XMP prior to the first sync.
 
Joined
Oct 28, 2015
Messages
72
Lightroom Experience
Advanced
Lightroom Version
Classic
When you create and sync a collection in LrC, any keywords are not automatically synced unless you happened to have saved metadata to XMP beforehand. But having said that, if you can see the keyword in LrWeb then it should find that when you search for it. So I don't qiuite know why it's not happening.

Country Code, like all the other location fields, do not sync to the cloud unless it was stored in XMP before the initial sync. So adding/changing it after sync will not have any visibility in the cloud, and as I said it also seems that it's not stored even if you had it stored in XMP prior to the first sync.
I may not have saved to XMP before syncing. I'll try that and see if that helps.

Thanks.
 
Joined
Feb 1, 2010
Messages
13,836
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic
I may not have saved to XMP before syncing. I'll try that and see if that helps.

Thanks.
It won't help if they're already synced.....as I said Keywords (and Location Data) simply do not sync between LrC and the cloud. The only way to get that data to the cloud is to save it to XMP before syncing the image for the first time (and only then if there ISN'T an existing Smart Preview for the image at the time of syncing).

You can remove the image from the cloud, then resync it (after deleting any existing Smart Preview then saving metadata to XMP), then the keywords and location data should arrive in the cloud (but apparently not Country Code).
 
Joined
Oct 28, 2015
Messages
72
Lightroom Experience
Advanced
Lightroom Version
Classic
I took all yours steps (remove from cloud including All Photos and Deleted photos, delete smart preview, save to XMP, then add to collection and sync) but I'm still not able to search for keyword or country.

I can see the keyword if I click on the tag icon but searching one of the keyword that I see in the cloud/LR Web finds 0 photos with the keyword. So the keywords are making it to the cloud but search doesn't find same keywords.

Same for country value. I see it in the cloud if I display information by clicking on the "i" button but search doesn't find that country.

So values are making it to the cloud but search doesn't find them.

To me it looks like a question of where search looks for search values.

Attached shows web Info display. Of the three location values (Brockagh, Wicklow, testcountry) search works if searching on first 2 but not third.
Screenshot 2022-11-21 at 17-43-36 Ireland 2022 photos.png
 
Joined
Feb 1, 2010
Messages
13,836
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic
I wish I could explain it, but I can't. I don't see any such problems when I add or change things such as keywords or location data. Provided I allow a few seconds for the change to sync, then refresh the browser window, searching in LrWeb always appears to be successful.....even when using "TestCountry" as the country as per your example.

Maybe log it as a potential bug at the official Adobe site (link at the top of the page)?
 
Top