• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Stuck creating previews

happygun

Active Member
Joined
Sep 30, 2010
Messages
144
Location
UK
Lightroom Experience
Intermediate
Lightroom Version
Lightroom Classic version: 9.3 [ 202005281810-476e492c ]
Operating System
  1. macOS 10.15 Catalina
I had some space issues on my drive and have removed the previews within lightroom. After resolving these issues i am now recreating the standard size previews, but Lightroom gets to 30502 out of 61867 (i think these are the already created previews as it gets to this number in a minute or so).
But Lightroom never progresses beyond this number. All drives are connected, i have restarted Lightroom, restarted the machine, tried building 1:1 previews and get to the same point, all without any success.
Any suggestions as to what to do do to fix?
 
Joined
Jul 2, 2015
Messages
11,627
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
You don’t have to force Lightroom to rebuild all previews. Just let Lightroom do this when needed.
 

happygun

Active Member
Joined
Sep 30, 2010
Messages
144
Location
UK
Lightroom Experience
Intermediate
Hi. But Lightroom doesn’t seem to be building the previews since I deleted the previous previews. Whenever I browse the external drive, it is very slow while Lightroom builds a preview before I can see the image in the loupe view.
I’ve done a restart of Lightroom after removing the preview file again and tried to kick off building the previews again. Let’s see how far it gets by tomorrow morning.
Ps. There definitely did seem to be some sort of error as Lightroom kept getting to the same number of previews before getting stuck (30502)
 
Joined
Jul 2, 2015
Messages
11,627
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Sounds like it may be stuck on one particular image. The only way to find out which one that is, would be to build previews per folder and by scrolling the grid, so you can watch the progress.

Because Lightroom needs to load the image in order to build a preview, a slow external drive can indeed slow down building of previews, but in the end they should all be built.
 
Top