• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 17 August 2022 It's Lightroom update time again and there's a couple of minor improvements as well as new cameras, lenses and bug fixes! See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Still unable to launch LrC newer than v11.0.1

dhampny

New Member
Joined
Apr 20, 2008
Messages
14
Lightroom Version
Lightroom Classic v11.0.1-v11.4
Operating System
  1. macOS 12 Monterey
I did post this issue on this Forum sometime ago and received some helpful but unsuccessful suggestions to fix my problem. I also posted on the Adobe support forum and had many more, but still unsuccessful, suggestions. I've re-posted on that forum and am posting here again with the hope I could find some new help that would solve my problem.

To recap, this is my situation: Mac mini 2018 running macOS Monterey 12.3.1. LrC v11.0.1 installs and runs fine but when I attempt to upgrade to v11.1, 11.2, 11.3 or 11.3.1 or 11.4, Lightroom hangs on the splash screen, won't open my catalog and I have to do a force quit to close out. With the release of v11.4 I had hoped my issue had been resolved but still no luck. I have posted about this previously and those earlier posts describe all the numerous solutions that have been suggested by many good people on this and the Adobe forum. I've tried them all without success, except that I am able to open LrC v11.4 when I boot up in Safe mode. I've then tried one-at-a-time opening apps that run constantly in Normal mode but each time I was still able to launch v11.4. None of them prevented me from opening v11.4. I understand this must mean that something running in the background is preventing me from launching v11.4 but I would really like to have the list of suspects narrowed down. If I can't resolve this I might have to start looking at alternatives to LrC as it seems foolish to keep paying monthly for software that I can't use beyond v11.0.1. I really don't want to give up Lightroom. Any new thoughts or suggestions would be welcomed. Thank you.

David
 
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic

dhampny

New Member
Joined
Apr 20, 2008
Messages
14
Thank you. Yes, I've tried that. I've also reset Preferences; I've tried reinstalling all of the newer versions; I've run Adobe CC Cleaner then reinstalled Creative Cloud and Lightroom; I've run OnyX; tried logging into another account; I've removed startup items to see if they were interfering somehow; I've uninstalled my A/V software; I've deleted third-party plugins. Nothing I've tried has made any difference. It's frustrating.
 
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
Just to triple-check, you granted Full Disk Access, as shown in the screenshot below? I ask, because on the Adobe forums, there have been more than a few instances of computer-savvy users, already quite familiar with Mac folder permissions, confusing Full Disk Access with Files And Folder Access (which they've been told to adjust in the past):

1655655787704.png


And for good measure, grant Accessibility to LR as well. Adobe recommends that, though I haven't seen any reports on the Adobe forums that it helps:

1655655822081.png
 
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
Reading the previous thread, it appears you tried opening other of your older catalogs, but not a brand new catalog? So try creating a new catalog with just a few photos in LR 11.0.1, then opening that catalog in LR 11.4.

By the way, on Mac, I've found I can copy an older version of "/Applications/Adobe Lightroom Classic" to my Desktop, with a newer version installed in /Applications, and can launch either version without having to reinstall/uninstall. (I do it all the time in developing my plugins and helping others troubleshoot.)
 

dhampny

New Member
Joined
Apr 20, 2008
Messages
14
What a great suggestion to make a copy of the application! Saves a good amount of time.
I created a new catalog with a few photos as you suggested. However, when I try to open it in v11.4 the program crashes and I get the error message captured in the earlier screenshot on the left. When I select Reopen in that error message, LrC v11.4 opens with only the header and filmstrip but no photos in the workspace as shown in the 2nd screenshot on the right. It also presents a different error message as shown. Does any of this give you any clues about what's wrong?
Thanks very much for your help.
 

Attachments

  • Screen Shot 2022-06-19 at 1.51.43 PM.png
    Screen Shot 2022-06-19 at 1.51.43 PM.png
    441.2 KB · Views: 23
  • Screen Shot 2022-06-19 at 1.52.29 PM.png
    Screen Shot 2022-06-19 at 1.52.29 PM.png
    483 KB · Views: 22
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
"An error occurred when attempting to change modules".

Haven't seen that error for years. There's an old Adobe troubleshooting note on that which, though it says it was updated in January, probably hasn't been really examined and updated in five years. The only thing that might be relevant to you is resetting preferences (again).

The only other thing I can suggest is to upload the new catalog's .lrcat file (that caused the crash) to Dropbox, Google Drive, or similar and post the sharing link here. We can verify that it opens in other LR installations (most likely it will, but we should double-check).
 

dhampny

New Member
Joined
Apr 20, 2008
Messages
14
I updated LrC on my MBP and v11.4 installs and launches with no problem. I had to create a new test catalog because my other test catalog wouldn't open and I got a message it was in use by another application and to quit the other copy of Lightroom. I didn't have another copy of Lightroom open.
 
Joined
Jul 2, 2015
Messages
12,332
Location
Netherlands
Lightroom Experience
Power User
I updated LrC on my MBP and v11.4 installs and launches with no problem. I had to create a new test catalog because my other test catalog wouldn't open and I got a message it was in use by another application and to quit the other copy of Lightroom. I didn't have another copy of Lightroom open.
What you need to do is open the catalog folder and look for a ‘catalogname.lrcat.lock’ file. Delete it and your catalog will open normally again. Lightroom creates this lock file to prevent other apps trying to open the catalog at the same time. On a normal quit, it deletes the file again, but the file can remain if Lightroom does not quit normally.
 
Top