SPOT REMOVAL PROBLEMS

PENNSTATEMIKE

New Member
Joined
Sep 3, 2015
Messages
16
Lightroom Experience
Intermediate
Lightroom Version
This is not a Lightroom problem per se but an issue I am running into. I scanned a bunch of old photos and they have some defects, mainly areas where the emulsion is missing causing white spots top appear on the scan. When I place my mouse over the photos, it just plain starts acting crazy - slow jumpy movements - and it is taking forever to repair the scans with spot removal. The mouse is OK until it gets onto the photo area. I've cleaned the mouse, replaced batteries, etc all to no avail. Anyone have an idea what might be causing this and offer a solution?

Many thanks
 
Joined
Jun 20, 2009
Messages
18,383
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Your profile says that you are running LR6.6. Earlier versions of LR6.x had some pretty nasty bugs, This could be one of them. You should update to LR6.9 to get the best code from Adobe. Then, you need to address the other problem and that is GPU acceleration. Since you are running OS X 10.11.x you might not have the best Video driver to be running LR6.x. Even id LR System info says the the GPU is supported and you have it enabled, I would disable GPU acceleration in Preference /Performance. By disabling GPU acceleration, I think your squirrelly mouse issues will go away. My recommendation would be to update your Mac to MacOS (Sierra 10.12.4) after you have updated to LR6.9. There is no reason to be running obsolete versions of your operating system.
 
Last edited:

PENNSTATEMIKE

New Member
Joined
Sep 3, 2015
Messages
16
Lightroom Experience
Intermediate
Lightroom Version
Thanks for the info. I did the update to 6.9. I was already on Sierra 10.12.4. I'm not sure how to access GPU acceleration. I googled and it appears it is for Illustrator. I have stand alone Lightroom, not CC. Still having the mouse problem but it doesn't happen when I switch to Photoshop Elements 12 to do the editing. Hoping I don't have to reinstall Lightroom for fear of losing everything.
 
Joined
Jun 20, 2009
Messages
18,383
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Go to LR preferences. Click on the Performance tab. In the Section labeled "Camera RAW" there is a check box labeled "Use Graphics Processor" I suspect it is checked. Uncheck it. Further to the right is that checkbox ia a button labeled {System Info} Click on that and the copy the contents of the dialog that opens. Paste the contents back into your reply here. With the System Info, I can better analyze your system problem.
 

PENNSTATEMIKE

New Member
Joined
Sep 3, 2015
Messages
16
Lightroom Experience
Intermediate
Lightroom Version
Hi Clee - GP was disabled. Below is the system info. I think I may have found the problem though. It only seems to be happening with the photo I recently scanned. This was scanned at 1200 dpi. I just rescanned at 300 dpi and all seems to be OK. Does that make sense?

Lightroom version: 6.9 [ 1106920 ]
License: Perpetual
Operating system: Mac OS 10
Version: 10.12 [4]
Application architecture: x64
Logical processor count: 4
Processor speed: 2.7 GHz
Built-in memory: 12,288.0 MB
Real memory available to Lightroom: 12,288.0 MB
Real memory used by Lightroom: 1,948.3 MB (15.8%)
Virtual memory used by Lightroom: 2,920.0 MB
Memory cache size: 351.5MB / 2,860.5MB (12.3%)
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2,AVX
Camera Raw virtual memory: 373MB / 6143MB (6%)
Displays: 1) 1920x1080

Graphics Processor Info:
Check OpenGL support: Failed
Vendor: ATI Technologies Inc.
Version: 4.1 ATI-1.50.38
Renderer: AMD Radeon HD 6770M OpenGL Engine
LanguageVersion: 4.10


Application folder: /Applications/Adobe Lightroom
Library Path: /Users/pennstatemike21/Pictures/Lightroom/Lightroom Catalog.lrcat
Settings Folder: /Users/pennstatemike21/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) Aperture/iPhoto Importer Plug-in
2) Canon Tether Plugin
3) Facebook
4) Flickr
5) HDR Efex Pro 2
6) Leica Tether Plugin
7) Nikon Tether Plugin
8) Perfect Effects 9

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Built-in Output
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x4
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon HD 6770M OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-1.50.38
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
 
Joined
Jun 20, 2009
Messages
18,383
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Everything is all up to date and the GPU disabled. These are the recommendations that I would give to solve the mouse problem. Except that it doesn't solve it. Your rescanned file is 1/16 the size of the one that causes problems. This should not be a problem except for slower processing times. You might have stumbled on the answer. Scan the image again at 600dpi. Let me know if the problem is apparent at 600 dpi. 600 dpi would be a minimum resolution for my preferences. I regularly process RAW images that are 36mp or slightly better than 600 dpi of an 8X10 image.
 

PENNSTATEMIKE

New Member
Joined
Sep 3, 2015
Messages
16
Lightroom Experience
Intermediate
Lightroom Version
Great minds must think alike. That's exactly what I did and it seems to be OK. The actual size of the photo is only 4.8" x 3.5". Its from way back in the '70s. I'm wondering if the high dpi along with that small physical size just makes it tough for Lightroom to process. As soon as the cursor hits the image everything goes haywire. I'm going to experiment with a large photo and see what happens at 1200. I was doing it at high resolution just to make sure I got all the defects on screen. Thanks so much for your help. I didn't realize I was so far behind on LR updates. My Mac software updates automatically.
 
Top