• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.
  • It's Lightroom update time again! Color Grading and improved zoom across the whole Lightroom family, plus graphical watermarks for the cloud-based Lightroom apps, as well as the usual new cameras, lens profiles and bug fixes. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Smart Collection Rule tripped by keyword "HeadDetail"

Joined
Mar 12, 2017
Messages
137
Lightroom Experience
Intermediate
Lightroom Version
I posted this to another thread and got no response; I'm creating a new thread in the hope that someone can help me.

I have made some progress figuring this out. Originally I couldn't understand why the rule

(1) {Keywords}{ends with}{Detail}

produced results that were at odds with my photos.

The rule

(2) {Keywords}{ends with}{etail}

worked as expected.

I have narrowed this down the the two-letter combination "dD" in my keyword "HeadDetail". Photos with a keyword that ends "HeadDetail" are not included using Rule 1 above. Many other combinations of "xDetail" (where "x" is a letter other than "d") return the proper results.

When I change the keyword to "HeaDetail", it is found by Rule 1 above.
When I change the keyword to "HeadzDetail" it is found by Rule 1 above.
All of them are found by Rule 2 above.

I have, in the Edit Keyword Tag dialog, deleted all the characters and typed them back in. No change.

I have not done exhaustive tests. Afaict, the problem is limited to:
- the Rule "Keyword" with the condition "ends with", and
- keywords containing the sequence "dD".

I am new to Lightroom — please don't rule out any form of user error.

I'm stumped.

Any help is greatly appreciated.
 
Last edited by a moderator:
Joined
Mar 12, 2017
Messages
137
Lightroom Experience
Intermediate
Lightroom Version
UPDATE

The issue seems to be any double letter.

Tried with keywords TheEnd and BackKick. Rule 1 (see top post), modified for either of these, fails to find them.

Note that capitalization does not matter. Have also tried "Headdetail" and "Theend".

From my limited experience, this looks like an error in a RegEx.
 

Paul B

Active Member
Joined
Nov 30, 2016
Messages
134
Lightroom Experience
Intermediate
Lightroom Version
6.x
From my limited experience, this looks like an error in a RegEx.
I don't think it's a regex; that should be fairly trivial usage (though I can see why a regex sprang to mind).

But there certainly seems to be a bug there. I've done a simple test and get the same behaviour.
 

jimburgess

Active Member
Joined
Mar 7, 2008
Messages
180
Lightroom Experience
Advanced
Lightroom Version

tspear

Senior Member
Joined
Sep 23, 2014
Messages
1,799
Location
Waltham MA
Lightroom Experience
Beginner
Lightroom Version
Looking at the bug report, I would guess Adobe is using the soundex functionality in the database. As such, there is very limited options for Adobe to utilize.
 
Joined
Mar 12, 2017
Messages
137
Lightroom Experience
Intermediate
Lightroom Version
Here's a thread from 2010
Thanks Jim for the link and for the advice. I'd estimate I've got 4 hours of trouble-shooting and 3 hours of working-around this bug already. More damaging than that cost is how worried I now am that I'll get bitten by more than another of these as I ramp up my use of Lightroom.

I added a comment with links (waiting for moderation) to that thread for those who might research the same issue.
 
Last edited:

tspear

Senior Member
Joined
Sep 23, 2014
Messages
1,799
Location
Waltham MA
Lightroom Experience
Beginner
Lightroom Version
I was just looking at the threads Jim and Louie pointed too, plus my personal experience with soundex.
Note: I do not work for Adobe, just looking at the behavior and results I am making a guess.
 
Top