• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Replication issues - why all the numbers are different

amiskin

New Member
Joined
Apr 7, 2021
Messages
1
Lightroom Experience
Intermediate
Lightroom Version
Cloud Service
Lightroom Version
Lightroom Classic 10.2 and Lightroom 4.2
Operating System
  1. macOS 11.0 Big Sur
I have been pulling out my hair for over a month trying to sort out replication issues between My Lightroom Classic (LrC) catalog and what is shown on Lightroom (Lr). I have now resolved this and thought I would post what did and did not work for me, in case others find similar issues.

The Symptoms
  1. LrC: All Photographs ("A") and All Synced Photographs ("B") and LR: All Photos ("D") all show different numbers.
  2. When I started a new collection called "All LRC PHOTOS ("F"), selected all in LrC "All Photographs" and added them to the collection and once it had synced to Lr, I selected "All Photos" in Lr and added them to the collection, I got yet a third number.
  3. Lr reported numbers (D) were different on my phone and on my iPad - and indeed on the web.
  4. Bizarrely, the number shown in the side panel for F is larger than the number of images shown on the Grid when the collection is selected.
This has arisen over the years as I used to import to LrC, but once going to Creative Cloud with 1TB, I decided only to use Lr for importing so that I was sure of a cloud back up for everything.

I spent over 4 hours on the phone with customer support, who frankly were worse than useless as they took up time and solved nothing, The solutions they proposed did nothing for me, other than duplicating loads of downloads from Lr. Their suggestions included Rebuild Sync Data, deleting catalog Sync.lrdata and starting a new catalog and using "File>Import from Another Catalog" . I have approx 60,000 images about 30k imported originally into LrC and another 30k from Lr.

What did work:
  1. Any version of Lr that is showing D differently from what is on the web, delete the app and reinstall it.
  2. Ensure that LrC knows where all its files are: (Library>Find All Missing Photos)
  3. Ensure all files in the Lightroom Sync preferences are cleared and you have a green tick on the cloud. If this is a problem there is lots of help on the web, but what worked for me was clicking on individual files and if they were on LrC, changing something to force a resync, if there were on Lr, clicking on the weblink and doing something similar. A few had a bizarre message about the Base Photo not being found, which turned out to be duplicates (by searching on filename) and could safely be deleted
  4. In LrC, create a blank collection, set up to sync with Lr called "Not Synced". Note the count in this in LrC ("C") and Lr ("E") - should be zero to start with
  5. In LrC, click on "All Synced Photographs" and then CTL-A to select them all. Then click on "All Photographs". Menu: Edit>Invert Selection and drag whatever is selected into the "Not Synced" collection you have set up. For me, all these files were video files which LrC and Lr sometime sync and sometimes dont apparently. On LrC, "C" was 616, while on Lr, "E" was 444.
  6. I now could show that A-C was the same as D-E and both equalled B
Hope this helps someone in the future. As for the side bar showing a different number from the Grid total, I never did understand that, but it is possibly to do with upper and lower case file locations. The cure was to delete the collection and to add it again from scratch after all the other things had been reconciled.
 
Top