• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 17 August 2022 It's Lightroom update time again and there's a couple of minor improvements as well as new cameras, lenses and bug fixes! See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Rename folders not possible

Status
Not open for further replies.
Joined
Feb 15, 2013
Messages
25
Location
Vienna, Austria
Lightroom Experience
Intermediate
Lightroom Version
Classic
Lightroom Version
10.1
Operating System
  1. Windows 10
Hello!
Since the last update I encountered some problems. One of them is still there: in the library module, when I rename a folder everything is o.K. in the moment (renaming also present in the windows (10) explorer,. But shortly after that this folder is shown as missing in LR, together with the photos. When I go to search for it - the name in the explorer is reset to the original name (which I can choose again - and everything is set to the situation before) . In this situation renaming needs a special work around: rename in the explorer and sync the folder in LR. But this cannot be the solution in the long run.
Has anybody encountered the same? What can I do?
Thank you for your help!

Andrea
 
Joined
Jul 2, 2015
Messages
12,370
Location
Netherlands
Lightroom Experience
Power User
Joined
Feb 15, 2013
Messages
25
Location
Vienna, Austria
Lightroom Experience
Intermediate
Lightroom Version
Classic
Thank you Johan for your reply. But unfortunately the link does not show me a way to solve my problem.
1. I am on windows 10, not on MAC OS
2. I do not move folders.
3. I do not have two similar folders with only the capitals as discrimination.

> I just want to add a word of description to an existing folder name. For example change 2019-04-10 to 2019-04-10_Easter.

This had been no problem since LR 2, but is since LR 10 and it is annoying.
I have enclosed a screenshot: the arrow points at the renamed folder which is stated as missing. When I look into the windows explorer, the name has returned to the original name (2019-06-09 in this case) and when I do the search in LR and select it, the name is changed to this original again.

This happened yesterday as has happened before. Today I cannot replicate it - which confuses me even more.

Thanks for any advice!
Andrea
 
Joined
Jul 2, 2015
Messages
12,370
Location
Netherlands
Lightroom Experience
Power User
This screenshot only shows that Lightroom thinks this folder is missing, so that doesn't tell much. If I understand you correctly, then you say that the renamed folder spontaneously gets its old name back, and that causes the missing folder problem. I would love to see a video that shows this in action.
 
Joined
Feb 15, 2013
Messages
25
Location
Vienna, Austria
Lightroom Experience
Intermediate
Lightroom Version
Classic
Thank you Johan for reviewing! Yes your assumption is correct. Unfortunately I cannot even tell if there was any action between the renaming and the spontaneous return to the old name. Maybe the problem is within the windows explorer? The problem is, that when I tried the same with the next folder before my second post, I could not replicate it. The only thing I could do is being careful while going on with my 2019 folders if it happens again. How could I take a video?
 
Joined
Feb 15, 2013
Messages
25
Location
Vienna, Austria
Lightroom Experience
Intermediate
Lightroom Version
Classic
Now it happened again - and I captured it in a video!
As you can see renaming a folder works as expected, but in the background Windows explorer returns to the original name. In LR the new name is there until I go to the next folder and then back - now it is marked as missing. Do you have an idea how to manage this behavior? My Windows 10 has all updates an all drivers got the most recent updates too.

MP4 Rename folder failed
 
Joined
Feb 15, 2013
Messages
25
Location
Vienna, Austria
Lightroom Experience
Intermediate
Lightroom Version
Classic
There is another strange behavior: sometimes when I try to rename a folder I get the message that "this is not possible". After the second or third try It works finally. Do you think there is a connection between these two cases?
 
Joined
Jul 2, 2015
Messages
12,370
Location
Netherlands
Lightroom Experience
Power User
Intriguing! I wonder if this could have something to do with the infamous 'Capitalisation problem'. Search this forum for that. Basically, what happens is that you have two different folders, one called ‘XXXX’ and the other one called ‘xxxx’. In other words, the names are the same, except for the capitalisation. Because MacOS and Windows are case-insensitive, your OS sees those two folders as one and the same folder and so it deals with this without you even being aware of it. You will only see one folder in the Mac Finder or Windows Explorer. But Lightroom is case-sensitive, so Lightroom does see two different folders. If Lightroom now renames one of the folders, the result might be that the other one is set to become visible for the OS.
 
Joined
Feb 15, 2013
Messages
25
Location
Vienna, Austria
Lightroom Experience
Intermediate
Lightroom Version
Classic
Thanks again Johan for your fast reply - even at Christmas time!
I will certainly look deeper into the problem you are mentioning. At the first glance I felt that it might not be applicable for me. My workflow for new photos including the setup of the root folders (hard drive C in a user folder with cloud synchronization) has been the same for the last couple of years. When I import new photos they are converted to DNG, get some basic edits and a copyright and are renamed according to the capture date. So I do not see 'capitalisation' at that point. Only when I am finished with the metadata and my edits the folders get a new name and are moved to an external drive. But only recently I was forced to renew the setup for the cloud synchronization, I will check the folders in the cloud as well - may be that's the problem ?

Anyway, I am happy with your advice and if I find something I will post it here!
Merry Christmas!
 
Joined
Jul 2, 2015
Messages
12,370
Location
Netherlands
Lightroom Experience
Power User
I am on Amazon Photos (Prime): the folder with new photos is synchronized, folders on other hard drives get a backup to the cloud folders.
I don’t know Amazon photos, but this may well be the cause of the problem. Maybe the synchronization stops the folder being renamed by third party apps.
 
Joined
Feb 15, 2013
Messages
25
Location
Vienna, Austria
Lightroom Experience
Intermediate
Lightroom Version
Classic
Hi, I still did not find out what caused the problem. Today I did some renaming on other folders and captured them by video. (one in the link) On the right side is LR in the library module, in the middle the browser with Amazon Drive opened at the same folder level and on the left side the explorer with the synchronized folder. Everything works as it should: the renaming is copied into the explorer and after some time (about 3-5 minutes) the new folder name also appears in the cloud drive (Synchronization time dependent on the internet connection). So in general this concept works, I just don´t know why not every time.

Rename o.K:
 
Status
Not open for further replies.
Top