Reconnecting Catalog To External Drive Backup...

Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#1
Lightroom Version
LR 3.6
Operating System
Other (please note in thread)
I have two external drive backups of my Lightroom images, Drive 2 and Drive 6. Drive 2 was recently dropped and I am unsure whether or not it might eventually fail so I want to stop using it and switch to Drive 6. Due to a misunderstanding of the proper procedure to follow I initially moved the year folders 2011 and 2012 from Drive 2 to Drive 6 (see screen shot) When I discovered that this was not the proper way to do it I attempted to reconnect the photos to the catalog by connecting drive 2 back to my computer, highlighting the year folder 2011, right clicking it, selecting Find Missing Folder, selecting year folder 2011 on Drive 2, and clicking on choose. When I tried to view the reconnected folder I found the much feared ? When I clicked on the ? I got an error message (see second screen shot) indicating the original file could not be found. Obviously I am still not doing this properly. any idea where I went wrong and what I need to do to fix things?

Thanks!

I am using OS 10.6.8
 

Attachments

Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#3
Johan,

I knew the drives were not connected when I took the screen shot, I just wanted you to be able to see the folder structure. That said your comment triggered a thought that may prove to be the solution to my problem. Soon as I get a moment I'll test it out and let you know what proved to be the problem.

Thanks!
 
Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#4
Johan,

When I dropped my external drive #2 and feared it might have been damaged I began trying to relink to my second backup drive #6. I mistakenly moved the year folders 2011 & 2012 off Drive #2 and on to Drive #6 thinking this was the correct proceedure. I can't remember how I did this as it was awhile ago and I got interrupted by other matters. My question now is how do I move those two year folders back to Drive #2 so that I can relink my catalog to my #6 backup drive. I tried dragging and dropping them like you would in Finder but it doesn't seem to work.

Thanks!
 
Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#6
Look at the Lightroom folder panel. That tells you how Lightroom expects the folder hierarchy to be.
Look at the Lightroom folder panel. That tells you how Lightroom expects the folder hierarchy to be.
I'm not sure what you mean by that?

If you look at the screen shot below you will see that I moved the year folders 2011 & 2012 that belong on drive #2 on to drive #6. What I need to know is how do I move those two folders back where they belong on Drive 2 so that I can update the catalog links to my second backup drive #6. I tried to just drag and drop the folders from one drive to another and it didn't work. Do I use Update Folder Location to move the folders or is there some other method?

Thanks!
 

Attachments

Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#8
Johan,

I hate to keep bothering you with all this but I must admit that I find Lightroom's handling of files very confusing! Reading your advice in your last response I interpreted it to mean that I should go into Finder and move the years 2011 and 2012 back into Drive #2. The problem is that both Drive #2 and #6 already have those years on them (see screenshots below. My problem is that within Lightroom itself Folders 2011 and 2012 are shown as being on Drive 6 but not on Drive 2. Since Drive 2 is the drive currently linked to the LR Catalog I assuming that I need to move 2011 & 2012 back to Drive 2 within Lightroom but I am so uncertain as to how Lightroom manages things I am unsure what to do or how to do it.

Could you give me step by step instructions on how to fix things?

Thanks!

low)
Screen shot 2018-07-26 at 8.23.07 PM.png

Screen shot 2018-07-26 at 8.23.58 PM.png
 

JohanElzenga

Lightroom Guru
Staff member
Moderator
Lightroom Guru
Joined
Jul 2, 2015
Messages
7,666
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Classic 7
#9
My problem is that within Lightroom itself Folders 2011 and 2012 are shown as being on Drive 6 but not on Drive 2. Since Drive 2 is the drive currently linked to the LR Catalog I assuming that I need to move 2011 & 2012 back to Drive 2 within Lightroom but I am so uncertain as to how Lightroom manages things I am unsure what to do or how to do it.
Right-click on the 2011 folder on Disk 6 in Lightroom and choose 'Update Folder Location'. In the standard MacOS X 'Open' dialog that follows, navigate to the 2011 folder on the Drive 2 disk and select it. Do the same with the 2012 folder.
 
Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#10
Johan,

Thanks! I suspected that was the case but was unsure. Lightroom manuals do a pretty good job covering the Develop Module but I find explaination of the behind the scenes management of files a bit vague at times.
 
Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#11
I followed the instructions above to connect the photos on my external backup drive #6 to my catalog but when finished I still get the missing ? on my photos. Not sure if I did something wrong or if there is another step I need to take. Could someone look at the screenshot below and see if they can figure out what the problem is?

Thanks!
 
Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#12
I followed the instructions above to connect the photos on my external backup drive #6 to my catalog but when finished I still get the missing ? on my photos. Not sure if I did something wrong or if there is just another step I need to take. Could someone look at the screenshot below and see if they can figure out what the problem is?

Thanks!
 

Attachments

clee01l

Senior Member
Staff member
Moderator
Lightroom Guru
Joined
Jun 20, 2009
Messages
13,921
Location
Bellaire, TX USA
Lightroom Experience
Power User
Lightroom Version
Classic 7
#13
Could someone look at the screenshot below and see if they can figure out what the problem is?
When you use Finder to go to the folder ".../14103OceanDriveStorm/" is the file "ShawD7_14103_72.dng" present? Lightroom does not think so. It has been moved or deleted outside of Lightroom. Clicking on {Locate} should take you to the same finder folder . Does it?
If you followed Johan's instructions
Right-click on the 2011 folder on Disk 6 in Lightroom and choose 'Update Folder Location'.
. Your Folder pane should now be showing a volume named "Toaster Drive 2". And this would now have the folder ".../14103OceanDriveStorm/"
 
Joined
Dec 4, 2014
Messages
99
Lightroom Experience
Intermediate
#14
Cleetus,

Thanks for the feedback. I am away from my office right now but soon as I get back I'll check out your suggestions and get back to you.

Thanks!
 
Top