• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! Just the usual new cameras, lens profiles and bug fixes. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes. If you use a custom monitor profile on macOS, note that the Classic performance bug is not yet fixed.

Problems with HEIC photos and Lr 10.1

Joined
Jan 9, 2012
Messages
25
Lightroom Experience
Intermediate
Lightroom Version
Lr Classic 10.1
Operating System
  1. macOS 10.15 Catalina
I'm have a very frustrating experience with my iPhone 12 PRO MAX HEIC photos after importing them into Lr 10.1 on my MBP running Catalina. Some, but not all, of the photos appear in the Library module. For the ones that do appear, all the metadata is accurately displayed in the right column. The photos can be enlarged to 100%.

However, in the Develop module when a photo is clicked on a message appears within each photo: "The file could not be found." Where do I go from here?
 
Joined
Sep 29, 2007
Messages
22,827
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
How did you go about importing them? And when you look at the thumbnails, is there an exclamation point on the thumbnail or not? If so, click on it and see where it thinks the file should be found.
 
Joined
Jan 9, 2012
Messages
25
Lightroom Experience
Intermediate
Thank you very much for your response! In answering your questions: I imported directly from the iPhone into the folder I designated on the right side of the import screen. There were 2 photos in the small batch which had exclamation marks on the thumbnail but the thumbnail itself was totally blank! When I clicked on the exclamation marks I got this message: "Lightroom has encountered problems reading this photo. You will not be able to make any adjustments to the photo." I hope this may be of some help and I look forward to any further suggestions you may have.
 
Joined
Sep 29, 2007
Messages
22,827
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Is it only those 2 photos that are having problems, or all of them? If you go to the folder in Finder, can you view all of the photos ok, including the two problem ones?
 
Joined
Jan 9, 2012
Messages
25
Lightroom Experience
Intermediate
The two photos that were blank in the Library module are OK in the finder! When I bought the iPhone 12 last week, there were several hundred photos that were transferred over from my iPhone 6. The vast majority of these have not been imported into Lr. (I shoot most photos with a Nikon DSLR.) With my new phone I took several test shots to check out each of the different lenses. When I connected the new phone to my MBP, all of photos showed up as candidates for import, but the new iPhone 12 shots were scattered here and there in the array. I unchecked all and then found the new shots, checked them specifically and then did the import. I'm assuming that the file numbers that appear in Lr are being assigned by the iPhone. (But I have never seen any file numbers in the Photos app on the phones. Is there a way to do this?) Now here's a mind-bending problem: The photos that were imported into Lr had file numbers from 2489 to 2520. Several of these had been edited in the new phone and therefore had a duplicate sidecar number. One of the photos, however, which appears in the Library module but not in the finder has a File number of 9990!!

What I have described here is probably very confusing, but if there is any light at the end of the tunnel, I hope you can show me the way out.
 
Joined
Jan 9, 2012
Messages
25
Lightroom Experience
Intermediate
Thank you, Paul, for your input. I'm wondering if you or Victoria have heard of or used the free app Photo Investigator. I have not yet tried it but evidently it would give me access to the the metadata info on the iPhone photos before they have been imported to Lightroom Classic
 
Joined
Jan 9, 2012
Messages
25
Lightroom Experience
Intermediate
The problems I have had with Lr 10.1 and my MacBook Pro remain and I am putting them to rest.

But the very good news is that all the issues I have previously described have been resolved on my 27" iMac (2017). Even new PROraw captures are working perfectly! My thanks to both of you for your suggestions and your patience with my troublesome questions.
 
Top