• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Problems with Book Module Collections

MarkP

New Member
Joined
Nov 17, 2018
Messages
1
Lightroom Experience
Advanced
Lightroom Version
Lightroom Version
7.5 and 8.0
Operating System
  1. Windows 10
I recently created a large photo book (302 images). I clicked on the Create Saved Book button and a Book Collection was created as expected. I closed LR and restarted the computer. The next day I restarted LR and I am now trying to create a new book. I created a new, completely separate, collection with 20 images in it. In the Library Module this collection shows the correct 20 images. When I highlight this new collection and go to the Book Module the collection in the left panel still shows 20 images but the filmstrip on the bottom shows all 302 images from the previous book along with the 20 new images. Clicking on Clear Book does nothing to help. I have tried this with multiple other collections, always with the same result. If I select a previously created Saved Book collection I get only the images that were saved for that book. Knowing that there are problems with LR v 8.0 I reinstalled 7.5. Same result.

I must be missing something but I can't figure out what.

Help
 
Joined
Nov 27, 2013
Messages
1,595
Location
Queensland
Lightroom Experience
Intermediate
Lightroom Version
Classic
I recently created a large photo book (302 images). I clicked on the Create Saved Book button and a Book Collection was created as expected. I closed LR and restarted the computer. The next day I restarted LR and I am now trying to create a new book. I created a new, completely separate, collection with 20 images in it. In the Library Module this collection shows the correct 20 images. When I highlight this new collection and go to the Book Module the collection in the left panel still shows 20 images but the filmstrip on the bottom shows all 302 images from the previous book along with the 20 new images. Clicking on Clear Book does nothing to help. I have tried this with multiple other collections, always with the same result. If I select a previously created Saved Book collection I get only the images that were saved for that book. Knowing that there are problems with LR v 8.0 I reinstalled 7.5. Same result.

I must be missing something but I can't figure out what.

Help

Yes I see exactly the same, but do not remember it as a problem in earlier LR versions.
I have seen this answer from an Adobe person that may answer the question-

"This is as designed as Lightroom Classic only supports one unsaved book.
This is done not to disturb any existing changes done to that unsaved book.

Say, you have two collections C1 with 10 photos and C2 with 20 photos.
When you click on C1, Lr will create an unsaved book(U1) with 10 photos, which is fine.
Next, when you click on C2, Lr will not create a new unsaved book. Rather it display U1 created earlier and the filmstrip shows(10+20) photos."
 
Top