• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

Publish Services Problem trying to publish to Instagram - Lightroom 6.14

Joined
Jan 23, 2014
Messages
27
Location
South Bucks.
Lightroom Experience
Intermediate
Lightroom Version
Classic 8
Lightroom Version
Lightroom version: 6.14
Operating System
Windows 7
Hello - I wonder if anyone can please help with this problem. I went to publish a couple of pictures to Instagram this evening, using the built in L/R Instagram tool and I get an error message - this is the first time I have ever had this issue:

? : 0 : attempt to index field 'media' (a nil value) (2)

Can anyone give me a clue what the problem is, and how I can fix it ?

Thank you very much for any help.
Regards Kelvin
 

Roelof Moorlag

Senior Member
Joined
Jan 27, 2013
Messages
1,064
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Classic 8
Recently i had a similar issue with LRinstagram plugin. The error was ?:0: attempt to concatenate field 'code' (a nil value) (1)
The images was published however but LR did not set the image as published. At the next publish action this image was published again.
When i upgraded from Classic 7.3 to 7.4 it did not occur again.
 
Joined
Jan 23, 2014
Messages
27
Location
South Bucks.
Lightroom Experience
Intermediate
Lightroom Version
Classic 8
Thanks for your replies , Cletus & Roelof.

I tried the advice to disable/re-enable the plugins and I also tried downloading the latest LRinstagram plugin, but unfortunately none of those ideas worked, so I then did some more Googling. (which maybe I should have done first) :)

It seems that Facebook (who own Instagram) have recently blocked uploads from desktop applications and now only mobile apps can upload.
There is a thread on an Adobe forum here
.
That's a real shame, as the workflow from Lightroom to Instagram suited me well
 

Roelof Moorlag

Senior Member
Joined
Jan 27, 2013
Messages
1,064
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Classic 8
It seems that Facebook (who own Instagram) have recently blocked uploads from desktop applications and now only mobile apps can upload.
There is a thread on an Adobe forum here
.
That's a real shame, as the workflow from Lightroom to Instagram suited me well
Yes, the Facebook uploads have changed but i don't see a causality with Instagram. My upload workflow via LRinstagram is working without problems this moment.
 
Top