• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

Printer Slowing Down

Joined
Feb 18, 2008
Messages
186
Location
Western NC High Country, USA
Lightroom Experience
Advanced
Lightroom Version
Classic
I've been printing some note card orders and have noticed that Lightroom slows down significantly after printing about 20-25 copies. Stopping, shutting down the program and restarting brings the print speed back to normal.

Anyone notice this? Is it related to the mythical "memory leak" problem supposedly known (?) to plague Lightroom?
 
Joined
Jul 2, 2015
Messages
10,111
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
I've been printing some note card orders and have noticed that Lightroom slows down significantly after printing about 20-25 copies. Stopping, shutting down the program and restarting brings the print speed back to normal.

Anyone notice this? Is it related to the mythical "memory leak" problem supposedly known (?) to plague Lightroom?
Your info says 'Lightroom 6.4 / CC2015.4'. Is that correct? If so, update to 6.7 / CC2015.7 and see if the problem persists.
 
Joined
May 12, 2011
Messages
3,300
Location
Canada
Lightroom Experience
Advanced
Lightroom Version
Yes, it sounds like a memory leak. You could tell Adobe about it. There's a link to an Adobe bug-reporting site at the top of the forum pages.
 
Top