• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The November 2019 Lightroom updates are now available. Lightroom Classic includes the ability to export the same photos as multiple sizes/formats in a single export, content aware fill for panorama edges and more. It does require a catalog format upgrade and there are updated system requirements, so you may want to wait a few days before upgrading.
    Lightroom (cloud-based service) has export options (such as TIFF format, renaming and color space), custom sort order on the desktop, copy/paste to multiple photos on iOS and more.
    The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Presets behaving strangely .. to say the least...

Bernard Smith

Member
Joined
Dec 21, 2017
Messages
30
Lightroom Experience
Beginner
Lightroom Version
Lightroom Version
Lightroom Classic CC Version 9
Operating System
macOS 10.14 Mojave
Lightroom Classic CC V9.. on Mac using OS Mojave.

Some of my downloaded / purchased presets on the left hand panel (in DEVELOP module) are a bit funny.
When you hover over them they change the image as you would expect.... but when you click to select the preset the image changes again and now it doesn't look like it did when I was hovering before selecting.. It seems to be with presets that have either radial filters or graduated filters in them. The radial filters shift position and the graduated filters darken.
The "native" Lightroom presets are OK.

I haven't got a clue what this is about so any help would be appreciated.

Cheers

Bernard Smith
 

Bernard Smith

Member
Joined
Dec 21, 2017
Messages
30
Lightroom Experience
Beginner
Lightroom Version
Lightroom Classic CC V9.. on Mac using OS Mojave.

Some of my downloaded / purchased presets on the left hand panel (in DEVELOP module) are a bit funny.
When you hover over them they change the image as you would expect.... but when you click to select the preset the image changes again and now it doesn't look like it did when I was hovering before selecting.. It seems to be with presets that have either radial filters or graduated filters in them. The radial filters shift position and the graduated filters darken.
The "native" Lightroom presets are OK.

I haven't got a clue what this is about so any help would be appreciated.

I made my own test preset today and just put two radial filters in it and saved it. I then opened LR again and used it on an image and it did the same. ie the radial filters moved when I went from the hovering position to selecting them. I will make another user preset that doesn't have radial or grad filter in but just a colour change and see if it does the same... will let you know.. I am just trying to narrow it down to what it is and then perhaps we can somehow get a solution.

I then created a preset with a radial filter in the top left and bottom right hand corners.

When I hover over this it shows the radial filters in the opposite corners but when I select it the image changed to the way that it was created .
So it's the preview which I get when hovering over the presets with radial or graduated filters in them that are definitely showing incorrectly on the image.

To test this theory I created a colour only adjusted preset and it worked fine. I then downloaded another preset and that worked fine as it had no radial or grad filter in it. I then added a grad to this one and saved it but when I apply this altered preset it did not show the radial filter that I added to it before saving it. So I think that we can say that it's a problem with any preset that has either a radial or graduated filter in it that are not previewing correctly.

I created a preset with a radial filter in the top left and bottom right hand corners. When I hover over this it shows the rads in the opposite corners but when you select it the image changes to the way that it was created

So it's the preview which you get when hovering over the presets with rad or grad filters in them that are definitely showing incorrectly on the image.

MY SYSTEM INFO:

Lightroom Classic version: 9.0 [ 201910151439-b660523e ]
License: Creative Cloud
Language setting: en-AU
Operating system: Mac OS 10
Version: 10.14.6 [18G1012]
Application architecture: x64
Logical processor count: 8
Processor speed: 4.2 GHz
Built-in memory: 24,576.0 MB
Real memory available to Lightroom: 24,576.0 MB
Real memory used by Lightroom: 1,418.1 MB (5.7%)
Virtual memory used by Lightroom: 3,523.1 MB
Memory cache size: 2.9MB
Internal Camera Raw version: 12.0 [ 321 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 585MB / 12287MB (4%)
Camera Raw real memory: 596MB / 24576MB (2%)
Displays: 1) 4096x2304

Graphics Processor Info:
Metal: AMD Radeon Pro 580


Application folder: /Applications/Adobe Lightroom Classic
Library Path: /bernard/BERNARD-2-2-2.lrcat
Settings Folder: /Users/christinebernard/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) ColorChecker Passport
4) Facebook
5) Flickr
6) HDR Efex Pro 2
7) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Built-in Output
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: 12.1x4
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon Pro 580 OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-2.11.21
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
Cheers

Bernard Smith
 
Top