• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 25 June 2024 It's Lightroom update time again! See What’s New in Lightroom Classic 13.4, Mobile & Desktop (June 2024)? for the bug fixes and new lens profiles. Warning... this is a minor dot release and does NOT fix some of the bugs introduced in 13.3, so if you reverted to 13.2 due to bugs (e.g. sync issues), we'd suggest you stay there for now.

Pixieset plugin publish error

Status
Not open for further replies.

Eagleburger

Member
Joined
Jan 4, 2014
Messages
51
Lightroom Experience
Advanced
Lightroom Version Number
Latest
Operating System
  1. macOS 12 Monterey
I'm getting an intermittent error message when I see the Pixieset plugin in Lightroom. The problem went away a few weeks ago but has now returned. Now I can't publish anything. The specific error message is as follows:

Can't update this collection
An internal error has occurred: src/pixieset.lrdevplugin/PixiesetAPI.lua:106: attempt to index local 'response' (a nil value)

Any ideas please?

Thanks very much!
 

Attachments

  • Screenshot 2023-10-22 at 17.25.03.png
    Screenshot 2023-10-22 at 17.25.03.png
    56.8 KB · Views: 59
There are a couple other recent reports of internal errors with the Pixieset plugin:
https://community.adobe.com/t5/ligh...ns/problem-with-pixieset-plug-in/m-p/14177544
https://community.adobe.com/t5/ligh...th-pixieset-uploads-after-update/m-p/14155519

The error message indicates a programming error either in the Pixieset plugin or in LR. The file path in the error message, "src/pixieset.Irdevplugin/PixiesetAPI.lua", suggests you may have an older or beta version of the plugin installed.

So remove the current plugin and download and reinstall the current version:
https://help.pixieset.com/hc/en-us/articles/115003009832

If that doesn't help, you'll need to contact Pixieset.
 
Thanks both. Here's Pixieset's response:

The error you’re encountering seems to be related to Lightroom’s most recent version updates (v13 and v13.1), and our Tech Team is currently looking into this further. We’ll provide more information as soon as we can! In the meantime, to help ensure you’re able to upload to your collections via the Lightroom Plugin successfully, the best solution would be to revert back to v12 of Lightroom. Adobe has more information on how to do this here.
 
I encountered the same problem using Lightroom version 13.0.1. I reverted back to version 13 and the problem was fixed.
So the plug-in is working with v13.0? I'm on 13.0.1. Looks like the Lr plug in hasn't been updated for quite a while...
 
Well I rolled back to v13.0 but I now get an error message telling that my files are too large! Hmmm.

Pixieset recommends that I upgrade my OS to Sonoma. I'm on Monterey now.

Does Lr work well on Sonoma please?

Thanks
 
Status
Not open for further replies.
Back
Top