• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

Photos linked to wrong hard drive

renouj21

New Member
Joined
Mar 25, 2011
Messages
21
Location
Cookham, Berkshire, England
Lightroom Version
6.14
Operating System
  1. macOS 10.13 High Sierra
I've been trying to sort out the missing photos in my LR6 catalog, and I've discovered that in some cases I've linked the photos to my backup hard drive. In other words the pathway and name is exactly as the main drive, except that the location is the backup drive. Is there an easy way to link back to the main drive? I've tried detaching the backup drive, but the folders with the missing photos aren't greyed out on the main drive, because they don't exist on that pathway! There are about 2000 photos, concentrated in a small number of folders, so it would be much better if there was a folder based method, rather than having to relink individual photos (which are in a multitude of sub folders). Many thanks
 

renouj21

New Member
Joined
Mar 25, 2011
Messages
21
Location
Cookham, Berkshire, England
Hi

You should fine the blog below helpful. Aim to update the folder location at the highest point possible (then all the folders under are sorted at the same time):

https://www.lightroomqueen.com/lightroom-photos-missing-fix/
Thanks, but my situation isn't quite covered by any of the options in that article. Basically I originally imported the files into the catalog from the wrong location, namely my backup drive rather than my main drive. I can get the photos back in LR easily enough by plugging in the backup drive, but I don't want to do this, I want to link them to the files on my main drive. If I unplug the backup drive then there are no greyed out folders, because the files I'm looking for were never linked to the main drive. So I'm left with the painstaking business of "locating" each individual photo in its new (main drive) location. Is there a workaround?
 
Top