• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again. Just some small tweaks as well as cameras/lenses and bugs! See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Person Keywords

jkrm

Member
Joined
Jul 14, 2011
Messages
36
Location
Virginia, USA
Lightroom Experience
Intermediate
Lightroom Version
Lightroom Version
Lightroom Classic version: 11.1 [ 202112022200-7fd1f998 ]
Operating System
  1. macOS 12 Monterey
I was just finishing up some photos I took of the family at Christmas, and noticed that while Lightroom recognized the faces of all my family members, the corresponding person keywords were not there. Did Adobe change something? When I look at one of the photos in loupe mode the names of the people are displayed below the photo, and if I click the face region button the face regions are all marked and named correctly, but no people keywords. I did find, though, that if I delete the name of a person from the person region and re-type the name, the keyword does show up. Could this be a bug in the auto face recognition?
 

jkrm

Member
Joined
Jul 14, 2011
Messages
36
Location
Virginia, USA
Lightroom Experience
Intermediate
Lightroom Version
That's a great idea but unfortunately I already got the person keywords entered for those photos. Later I think I will take a photo, import into Lightroom, and see if the same thing happens.
 

jkrm

Member
Joined
Jul 14, 2011
Messages
36
Location
Virginia, USA
Lightroom Experience
Intermediate
Lightroom Version
Well, I can't reproduce the problem. If I add a face region and name it, the person keyword appears in the Keywords panel. If I delete that keyword, then "1 unnamed person" appears below the photo in loupe view, as it should. When I made my original post, I had photos with person names below the photo in loupe view, but no corresponding person keyword.

If it ever happens again, I'll take a screenshot and post.
 

BobT

Active Member
Joined
Apr 7, 2009
Messages
297
Location
Australia
Lightroom Experience
Advanced
Lightroom Version
Classic
The "People" feature may be great if you have lots of crowd photos and you need people to be picked out quickly but for my personal use, I don't trust it. I've seen it put names to weird features and miss real people. That might not be an issue for you. I prefer to do it manually with a key word hierarchy such as "People">"Family", "Friends", "Randoms">"Surname">"First names".
 

jaime105

New Member
Joined
Apr 2, 2022
Messages
3
I am facing the same issue. When I look at one of the photos in loupe mode the names of the people are displayed below the photo, and if I click the face region button the face regions are all marked and named correctly, but no people keywords. This happens on some pictures but not all.
I have attached a screenshot with an example. The highlighted keywords (person keywords) should be set since their related faces areas are set. However, they are not. If I reenter the name in the face areas, the keywords are then correctly set. So the issue can be corrected manually (one by one) but I can't find a way to identify the photos with this issue.
 

Attachments

  • Screen Shot 2022-04-02 at 3.53.15 PM.png
    Screen Shot 2022-04-02 at 3.53.15 PM.png
    2 MB · Views: 27

jaime105

New Member
Joined
Apr 2, 2022
Messages
3
Thanks. That is a good point. I though of that as well. However, I confirmed that there are not multiple occurrences of these keywords.
 
Joined
Apr 3, 2012
Messages
1,417
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
can't find a way to identify the photos with this issue.
You can use the Any Filter plugin with this filter:

1648947190566.png


Before invoking it the first time (and after changing the faces or keywords of any photo), be sure to select all the photos you're searching and do Metadata > Save Metadata To File.

This finds all photos that have at least one face region with a name assigned but no Person keywords assigned.
 
Joined
May 9, 2015
Messages
1,068
Location
Palo Alto, CA
Lightroom Experience
Power User
Lightroom Version
Classic
I have also noticed a disconnect from time to time between what is flagged in the keyword list compared to what is shown in the face regions. It seems that a link of some sort gets dropped (or never created) between the Keyword List and a seperate list of face regions. As Jaime noted, the face regions show with the proper (non redundant) keywords but the keyword in the Keyword list is not marked as being associated with the image. I don't have a case in my catalog right now that I can point to or test with, but as I recall I can highlight several images with this problem for the same person then just assign the KW from the KW list to those images. It's not clear though if this is linking the face region from each image or just associating the KW with the entire image (probably the later) - but either way one can now filter on the KW and find those images.
 

jaime105

New Member
Joined
Apr 2, 2022
Messages
3
Many thanks, John. I used the "Any Filter" plugin as suggested and I was able to identify the corrupted photos. Then, I manually fixed them.
Thank you again!
 
Top