• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 21 February 2024 It's Lightroom update time again! See What’s New in Lightroom Classic 13.2, Mobile & Desktop (February 2024)? for all the update news. It's mainly new cameras, new lenses and loads of bug fixes in this release.

Page Setup in LrC

Status
Not open for further replies.

rog

New Member
Premium Classic Member
Joined
Nov 19, 2019
Messages
1
Lightroom Version Number
LrC 12.1
Operating System
  1. macOS 13 Ventura
When in the Print Module selecting the Page Setup button immediately causes LrC to crash. I have reinstalled my printers, uninstalled and reinstalled LrC, and restarted my computer but the issue persists. Is there anything else I should try?
 
I have the same problem. I am using an Epson R3000, new iMac24, Ventura and the latest versions of the Epson driver and Lightroom Classic. If I press Page Setup Lightroom crashes. I have tried resetting my preferences but that did not work. I have deleted and added the printer several times and I am using the Epson driver, not AirPrint. I cannot tell if this is an Epson, Adobe or Apple issue. I can change the paper size for printing in Photoshop. Anyone have any suggestions? Thanks.
 
The Page Setup crashing problem is noted on this website in the Lightroom Queen article Lightroom and macOS 13 Ventura Compatibility. The link in the article leads to a discussion on the Adobe Community where Adobe is requesting more info. That thread was started in November and is now seven pages long. There is no word on why the problem still exists; maybe the root cause hasn’t been isolated, or maybe Adobe can’t fix it if it’s a bug in macOS 13. Link to the Adobe discussion:
P: Print Module, Page Set Up Crashes Lightroom Classic V 12.0.1

My production Mac is still on macOS 12 Monterey, but I have an older Mac on Ventura where this problem isn’t happening — when I click Page Setup in Lightroom Classic 12 for my Epson 3880, Page Setup opens as expected. I don’t know why Page Setup works fine on my Ventura Mac. It’s an Intel Mac, so if only Apple Silicon Macs are crashing, that might help isolate the problem.

One thing to try: When there is a serious problem with printing on macOS that isn’t solved by reinstalling the application or the printer driver, a “nuclear option” to try is resetting the macOS printing system. I don’t know if it will actually help with this problem, but be aware that it will reset everything about printing including wiping out all installed printer drivers, their custom paper sizes, and custom printer presets on the macOS side. (Print settings stored within application settings are not deleted.) If you want to try it anyway, first back up your Mac, and then follow the Apple instructions:
Reset the printing system on your Mac to solve a problem (Apple)
 
If you're using an Epson printer then the Epson Print Layout app is well worth a look. I use it, do a simple export from Lightroom to hard drive, you can then just drag and drop into the app!
 
If you're using an Epson printer then the Epson Print Layout app is well worth a look. I use it, do a simple export from Lightroom to hard drive, you can then just drag and drop into the app!
You can even export directly to the Epson Print Layout, instead of hard drive, if EPL is defined in the LR plug-ins.
 
I also had this problem when I got a new Epson XP-15000, going into Page Setup immediately crashed Lightroom. I was ready to send back the printer, but for a totally unrelated issue I needed to reinstall Ventura on my Mac Mini.

So I erased my drive, installed Ventura, added the printer via the XP15000_Lite_64NR_NA.dmg package, installed Lightroom, and re-imported my photos into a brand new catalogue. No more crash when going into Page Setup.

Fortunately, my Lightroom is set to always write any changes to an .xmp file, I didn't lose my edits when I created the new catalogue.

Granted, this is the nuclear option, but in now works without issue. If I didn't have the other issue, I probably would have tried to un-install Lightroom, re-install, and rebuild a new catalogue. At this point I don't know if that would have worked or not.
 
Status
Not open for further replies.
Back
Top