• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Nikon Tethering Problem

reinharw

New Member
Joined
Jan 3, 2016
Messages
5
Location
Portland, OR
Lightroom Experience
Intermediate
Lightroom Version
Classic
Lightroom Version
9.2
Operating System
  1. Windows 10
Is anyone else having a problem tethering their Nikon Z7 camera to Lightroom Classic (Ver 9.2). I am. LR searches for the camera but can't find it. I find that strange because my PC shows the connection to the camera and I can see the files on the storage card in Windows explorer. I spoke to Adobe support and was told it was a known problem with ALL Nikon cameras in both Lightroom for Windows and MAC versions. I was assured they were working on a fix. As big a deal as that would seem to be for professional studio photographers, I see little to nothing showing up on the internet about it. Any info anyone has to confirm or deny the problem would be greatly appreciated. A solution would be even better. I contacted Nikon support who would not acknowledge a problem and only suggested I contact Adobe. I'm very frustrated because this has been going on for a while.
 
Joined
Jan 18, 2009
Messages
2,455
Location
Fort Myers, FL
Lightroom Experience
Advanced
Lightroom Version
Classic
If you haven't tried it, remove the memory card before trying to tether. in older versions (and different cameras) on windows something (adobe or the OS) tried to enumerate what is on the camera's card before it would come ready to work. If you have a lot of images there it can take a long time. I no longer have my Nikons but I know they were always a bit flakey and required a few tries, but I found it much more consistent with no cards (or a freshly formatted card is fine also).

One other thing to try is install Nikon View NXi (free) and see if that works for download, since it uses much the same drivers (etc), notably there's an option there to set the camera time. If that does NOT work then look for other issues such as cable, etc., not Adobe. If it does work it doesn't get you any closer really, but you can at least eliminate other hardware issues.
 

reinharw

New Member
Joined
Jan 3, 2016
Messages
5
Location
Portland, OR
Lightroom Experience
Intermediate
Lightroom Version
Classic
Is anyone else having a problem tethering their Nikon Z7 camera to Lightroom Classic (Ver 9.2). I am. LR searches for the camera but can't find it. I find that strange because my PC shows the connection to the camera and I can see the files on the storage card in Windows explorer. I spoke to Adobe support and was told it was a known problem with ALL Nikon cameras in both Lightroom for Windows and MAC versions. I was assured they were working on a fix. As big a deal as that would seem to be for professional studio photographers, I see little to nothing showing up on the internet about it. Any info anyone has to confirm or deny the problem would be greatly appreciated. A solution would be even better. I contacted Nikon support who would not acknowledge a problem and only suggested I contact Adobe. I'm very frustrated because this has been going on for a while.
Thanks, I'll give it a try. - Bill
 
Top