• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! New cameras (including the Canon R5/R6), lens profiles and bug fixes, and the ability to disable built-in lens corrections for specific new cameras. Here's the usual list

Library module Moving folders closes hard drive in folders list

Joined
Jul 8, 2017
Messages
79
Location
Scotland
Lightroom Experience
Advanced
Lightroom Version
Classic
Lightroom Version
LrC 9.4
Operating System
macOS 10.15 Catalina
I'm in the Library and I have two hard drives under 'Folders' in the Folder Panel. One drive in my Mac's internal SSD, the other an external. I'm moving files from the internal to the external, something I've done may times before. I simply drag 'n' drop from the internal to the external.

I see the images 'disappear' as they move , again, usual. Not so usual is what happens once the move has completed. Both drives - what's the correct description? - close. The triangle to the right of their names switches so I only see the drive name, not the list of enclosed folders.

I'm sure this is a new 'feature'.

It's also a pain as I'm moving a number of folders and I have to reopen the list every time.

Is it just me...

Thanks!
 
Joined
Nov 5, 2017
Messages
855
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
Is this a Mac thing or are Windows users seeing it as well? Also, if David and Akrabat could let us know what version of LrC you are each running that may prove helpful.
Not sure this helps, still trying to figure, but it doesn't happen for me (Mac, 9.4)
 
Joined
Dec 28, 2008
Messages
33
Location
Worcester, UK
Lightroom Experience
Intermediate
Lightroom Version
Classic
I've created a screencast that shows what I see: https://www.flickr.com/gp/akrabat/RP3GRW

Note how the two drive sections collapse after a folder move between them. The first drive section then reopens itself, but the second drive section stays closed and has to be manually reopened so you can move move the next folder.
 
Joined
Jul 8, 2017
Messages
79
Location
Scotland
Lightroom Experience
Advanced
Lightroom Version
Classic
I've created a screencast that shows what I see: https://www.flickr.com/gp/akrabat/RP3GRW
That's pretty much what I'm seeing. However neither of my folder lists reopen in the way Rob's do (in the video one folder list reopens, the other stays closed).
Also, if David and Akrabat could let us know what version of LrC you are each running that may prove helpful.
LrC version 9.4. macOS 10.15.8
Not sure this helps, still trying to figure, but it doesn't happen for me (Mac, 9.4)
Could it make any difference that my external HD is a network drive? (Please don't confuse this with not being able to run LR on a network, that's a totally different thing!) Anyone else seeing this using network attached drives, or are your external drives plugged into your Mac directly via USB/Firewire/Thunderbolt?
 
Joined
Dec 28, 2008
Messages
33
Location
Worcester, UK
Lightroom Experience
Intermediate
Lightroom Version
Classic
Could it make any difference that my external HD is a network drive? (Please don't confuse this with not being able to run LR on a network, that's a totally different thing!) Anyone else seeing this using network attached drives, or are your external drives plugged into your Mac directly via USB/Firewire/Thunderbolt?
The drive that remained closed is a network share. The one the re-opened is my internal drive.
 
Joined
Jun 20, 2009
Messages
16,581
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Not sure this helps, still trying to figure, but it doesn't happen for me (Mac, 9.4)
Doesn't happen here either.
In the following order, I would take these steps repeating the Folder move process after each one until the problem disappears:
  1. Reboot the computer.
  2. Rename Preference and restart Lightroom forcing a new Preferences file to be created.
  3. Revert to v9.3 to see if the problem exists in that version. If it does not then reinstall v9.4
  4. If the problem still exists in a reinstalled 9.4 we can investigate differences between your hardware system and what Paul and I have .
 
Joined
Dec 28, 2008
Messages
33
Location
Worcester, UK
Lightroom Experience
Intermediate
Lightroom Version
Classic
Doesn't happen here either.
In the following order, I would take these steps repeating the Folder move process after each one until the problem disappears:
1. Reboot the computer.
2. Rename Preference and restart Lightroom forcing a new Preferences file to be created.
3. Revert to v9.3 to see if the problem exists in that version. If it does not then reinstall v9.4
4. If the problem still exists in a reinstalled 9.4 we can investigate differences between your hardware system and what Paul and I have .

Seems that it's been happening for a while for some people: https://feedback.photoshop.com/phot...assic-collapsing-working-folders-after-moving

Last week I did the reboot, reinstall and clean preferences thing while gathering data for an Adobe employee related to syncing. Unfortunately, I forgot to test this when I had 9.3 installed, so I’ve done the whole dance again which has helped.

LrC 9.3 collapses the drives but reopens them: https://www.flickr.com/gp/akrabat/0q0L8R
LrC 9.4 now does the same as 9.3 which is nice, though I wish it wouldn't collapse them.

Of course, I’ve lost all my preferences so I’ve manually put back the ones I care about and so far it’s just doing the collapse and reopen thing. I’m a little concerned it’ll come back though, but I suppose keeping my settings as close to the defaults as possible lowers the risk that it'll go wrong.

*shrugs* No doubt I'll be deleting all preferences and reinstalling again from scratch when 9.5 comes out to get the sync thing fixed!
 
Joined
Jun 20, 2009
Messages
16,581
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
*shrugs* No doubt I'll be deleting all preferences and reinstalling again from scratch when 9.5 comes out to get the sync thing fixed!
You should not need to. The reason for renaming the Preferences file is so that you can revert back to that file if building a new preferences file does not help.
 
Joined
Jul 8, 2017
Messages
79
Location
Scotland
Lightroom Experience
Advanced
Lightroom Version
Classic
In the following order, I would take these steps repeating the Folder move process after each one until the problem disappears:
  1. Reboot the computer.
  2. Rename Preference and restart Lightroom forcing a new Preferences file to be created.
1. Didn't help.
2. I can't see where the Lightroom preferences are. There are plenty of Adobe prefs, but nothing obvious like com.adobe.lightroom.plist. Anyone point me in the right direction and I'll continue.

Meanwhile I tried moving folders on a different catalouge but got the same result. Although there only one folder list remained closed whereas on my main catalouge both stay shut. But anyway, its' not a calalouge rather than an application issue.
 
Joined
Jul 8, 2017
Messages
79
Location
Scotland
Lightroom Experience
Advanced
Lightroom Version
Classic
3. Revert to v9.3 to see if the problem exists in that version. If it does not then reinstall v9.4
OK, I found the preferences and that didn't work. I am now finding now that the folder lists are reopening again, but no folders are highlighted and I seem to be looking at a randon set of every picture in my catalogue - in other words I'm lost navigation wise....
 
Joined
Jul 8, 2017
Messages
79
Location
Scotland
Lightroom Experience
Advanced
Lightroom Version
Classic
OK, I've been through @clee01l 's list, I'm back to 9.4 and there is progress. Both my folder lists reopen (although I'm sure they shouldn't shut in the first place).
However once they do reopen I'm lost. I can't remember how things were but surely I should be in the folder I moved, that was the last thing I selected. Instead I have all my pictures in the Browser window and nothing selected in the Folders lists. One of the picture I moved in the folder is selected in the Browser. As I say, that's not how I remember being left when moving files in the past. What do other fold see?

Thanks!
 
Top