• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • Lightroom Classic users who are running 13.3... 13.3.1 is now out with the following bug fixes:
    1. Location fields go missing after syncing the images
    2. Map Search is not returning a result
    3. There are no notifications for new likes in 13.3
    4. Crash while applying Remove on Windows
    5. When editing with Smart Previews instead of Originals, the source heal/clone area cannot be moved
    6. Mismatch between the brush size and the mask created
    There are still outstanding new bugs, mostly around sync and writing to XMP, so if these are essential in your workflow, you may want to stick to 13.2 for now. See the list at the top of our blog post for more details.

Export Metadata in Watermarks

PeterStewart

New Member
Premium Classic Member
Joined
Apr 3, 2019
Messages
14
Lightroom Version Number
Lightroom Classic version 13.2
Operating System
  1. Windows 11
Hi,

Does anyone know how to incorporate metadata into watermarks?
In certain cases I would like to be able to include shutter speed, aperture, ISO & lens data as part of a watermark. Is anyone aware of if/how this can be easily achieved?
TIA
 
You can't do it in LR itself but need to use the LrMogrify plugin.
 
You can't do it in LR itself but need to use the LrMogrify plugin.
I have a very similar requirement - but could not get LrMogrify to work (macOS, M2Ultra). From a number of other comments it seems to have been broken by one of the more recent LightRoom updates and is an orphaned software package (last updated 2019).
I have seen references to EXIF wMarker - but that is Windows only.
I can generate almost what I need via Print to JPG - but that messes up the filenames as well as having a few other problems.

Any other suggestions? - I need something I can run against the 4000 odd JPG images in my NAS screensaver folder - though can regenerate a new export direct from Lightroom if needed.
 
I have a very similar requirement - but could not get LrMogrify to work (macOS, M2Ultra). From a number of other comments it seems to have been broken by one of the more recent LightRoom updates and is an orphaned software package (last updated 2019).
What exactly is the problem when you try to use Mogrify? It works correctly on my MBP running Sonoma 14.3.1, LrC version 13.2.
 
What exactly is the problem when you try to use Mogrify? It works correctly on my MBP running Sonoma 14.3.1, LrC version 13.2.
There was an initial permissions issue regarding the ImageMagik module - but I was able to clear that - but after that every attempt to use the text Annotation feature failed with an error :-
mogrify: UnableToOpenConfigureFile `type.xml' @ warning/configure.c/GetConfigureOptions/739.
mogrify: UnableToReadFont `helvetica' @ error/annotate.c/RenderFreetype/1383.

Changes to the font type/size made no difference - Sonoma 14.3.1/LRC 13.2 also
 
I just successfully installed and ran LR/Mogrify2 5.10 on my LR 13.2 / Mac OS 14.2.1. The error you quoted comes from a problem with the Imagemagick installation. (I include Imagemagick in a couple of my plugins.)

[I]"There was an initial permissions issue regarding the ImageMagik module - but I was able to clear that"[/I]

What precisely did you do?

Try deleting LRMogrify2.lrplugin from your computer and redownloading/installing. Post screenshots of any errors you see.
 
Last edited:
Oh, I get a similar error when I don't select a Font Name in the Text Annotations filter. Evidently, the old version of Imagemagick included in LR/Mogrify 2 doesn't know how to find the default Helvetica on newer Mac OSes.

To avoid the error, choose a font file explicitly:

1712019830646.png


Navigate to /System/Library/Fonts or /Library/Fonts to choose a suitable font.
 
Back
Top