• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The August 2019 Lightroom updates are now available. Lightroom Classic includes advanced GPU support, batch HDR/pano merge and more. Lightroom (cloud-based service) has deleted photos on the desktop/mobile apps, as well as video support and batch metadata editing on Android. The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

"merging" metadata and photographs

Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
Lightroom Version
Lightroom Classic version: 7.5 [ 1186149 ]
Operating System
macOS 10.13 High Sierra, iOS
I'm currently in the process of merging back into my Lightroom catalog a few years of photos that went into Apple Photos and were put in albums, sometimes edited, over there. I've described the first part of my process here: Moving From Apple Photos to Adobe Lightroom Classic CC

Right now I'm faced with the following situation that I'm having trouble solving: I have duplicate photos which do not have the same name, sometimes not the same capture time (don't ask me why!), and different sets of keywords, catalog belonging, and sometimes develop settings. But often it's really just the keywords.

I don't want to copy one set of metadata upon another, I'd like to "merge" the metadata into one of the photos, ideally to delete the second one.

OR I'd at least like to be able to "make" one photo the virtual copy of the other.

My apple photos are imported through a temporary catalog, but unfortunately as the names have changed Lightroom does not recognize the new photos I'm importing through this catalogue as duplicates of the ones already in the master catalog. I'm wondering if maybe there is a way to manage this bit better.

Suggestions or ideas welcome! Thanks in advance.
 
Joined
Oct 8, 2007
Messages
5,069
Location
London
Lightroom Experience
Power User
Do the pairs of photos share the same capture time? If so, you might use my Syncomatic plugin which copies metadata from one file to another using either filenames or capture times to match up images. You can test it on up to 10 photos at a time.
 
Joined
Oct 8, 2007
Messages
5,069
Location
London
Lightroom Experience
Power User
It copies, but you can choose to exclude keywords or merge/add them to the existing keywords. The trial version works fully, just limiting you to 10 photos at a time, so you could get a good idea if it would be helpful.
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
I'm having a look, but unfortunately the plugin seems to want files with the same base name and a different extension. In my case they are the exact same files only they live in different folders. they're "real" duplicates. I don't know why Lightroom didn't recognize them as such when I imported the catalog back in :(
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
Now that I'm thinking more about this, there definitely seems to have been a problem when I imported the "new" photos from the temporary catalog. I was expecting lightroom to recognize that some of these photos were the same. It didn't. I assumed it was because their name was not identical, but now that I'm actually going through the photos, I'm finding that in many cases the name WAS identical and LR didn't recognize them as duplicates and invite me to just update metadata of images already in the catalog.

I found this thread (reading it now) and wonder if I'm having a related problem: Lightroom: No suspected duplicates when imported from catalog and some imported photos don't show in Library | Photoshop Family Customer Community
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
oh... I think this could be the problem. From that other thread:

"Lightroom does not seem to preserve duplicate file information when importing photos that were exported from another catalog."

in the current situation, I imported a pile of photos into a catalog I had produced by exporting some stuff "to catalog" (hence a "temporary catalog"). so
  • I created a temporary working catalog by exporting from my master catalog
  • I imported 20k "new" photos from Apple Photos into that working catalog
  • I did stuff to those photos (mainly, marked some as rejected)
  • I exported one year of those photos to another temporary catalog as a test (this is the step that I suspect might have created the problem)
  • I imported that second-generation temporary catalog into my master catalog
  • LR did not recognize that a large part of the photos in that temporary catalog were exact duplicates of photos already in the Master catalog (this seems to be the actual issue I need to solve -- if this works as intended then I will not be in the situation to need to merge keywords from duplicate photos in my main catalog, as this will have been taken care of in the import process)
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
I'm making some progress with syncomatic, but stuck. I've now understood I need to select two folders or collections so that there is a "source" and a "destination" (I was selecting the parent folder which contained my source and destination, previously).

I tried merging keywords on a small set of photos, but it seems to have silently failed (the keywords have not changed). Screenshot attached. I guess I am probably still missing some understanding of how this is supposed to work.
 

Attachments

Joined
Oct 8, 2007
Messages
5,069
Location
London
Lightroom Experience
Power User
You need to select the option to match using capture time. Now, if the capture times don't match, and filenames don't, then you're running out of automatic options.
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
So, I'm even more interested in figuring out how to get syncomatic to work now. After pottering around I think I definitely have an "import from catalog; doesn't identify duplicates" issue that doesn't seem to have a solution. Photosweeper looks very promising as a way to help me clean out the hundreds (thousands) of duplicates I'm going to end up with. And if I can actually get syncomatic to merge keywords for those duplicates before I cull them, I have my solution!
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
Reporting further: I've tried syncomatic again on a test catalog. I managed to make it work ONCE on two sets of duplicates. I tried again on two other neighbouring photos, same folders... and can't for the life of me make it work again! This is baffling.
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
So, I figured out the problem, @johnbeardy : syncomatic only works once after I open a catalog. Is it because it's in trial mode?

Here's what happened. I tried to run it on 4 photos. It worked. I tried on four others. It didn't. I closed the catalog. Opened it. Tried again on the four photos on which it had failed. It worked.

To make sure, I did the whole thing again.

Will this problem go away with the registered version? If so, then I think I have the tool I need!
 
Joined
Oct 8, 2007
Messages
5,069
Location
London
Lightroom Experience
Power User
You shouldn't need to reopen the catalogue like that. In trial mode it's limited to the first 10 photos that it can sync, then you have to close the dialog and select 10 more.
 
Joined
Oct 8, 2007
Messages
5,069
Location
London
Lightroom Experience
Power User
I've tested it today and as far as I can tell it is working correctly. Are both sets of pictures selected?
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
I've found a solution to rename my photos that had leading whitespace: Removing leading whitespace from filenames (how to)

So, here are two things I'm going to try (in order):

- export keywords from photos imported from Apple Photos using LR Transporter, and try and apply them to existing photos in the library (hoping that me fixing the filenames will allow existing photos and "apple imported" photos to match)
- if that doesn't work, see if I can get syncomatic to work... to copy metadata within pairs of matched photos based on capture time
 
Joined
Mar 21, 2018
Messages
60
Location
Lausanne, Switzerland (temporarily: Pune, India)
Lightroom Experience
Intermediate
Lightroom Version
@johnbeardy, I got a license for syncomatic just in case my issues were due to having a limited version. I'm still not able to make it work (it worked on one pair of selected photos but not the other, and when I tried on another few pairs it didn't work). Any idea what troubleshooting steps I could take? I've verified and double-verified that the filenames match.
 
Top