• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 17 August 2022 It's Lightroom update time again and there's a couple of minor improvements as well as new cameras, lenses and bug fixes! See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

LR Ver 11.4 Bug?

Joined
Dec 29, 2018
Messages
7
Lightroom Experience
Advanced
Lightroom Version
Cloud Service
Lightroom Version
11.4 (June 2022)
Operating System
  1. Windows 10
It appears that the "Boundary Warp" option for creating Panoramas in Lightroom Classic is broken with the latest version. In my attempt to merge 6 images into a panorama, the other automatic options work (AutoCrop and Fill Edges), but selecting Boundary Warp under "Photo - Photo Merge - Panorama" now simply cuts off the top of the image. In the extreme case (100%) it leaves only about 5% of the image height (the width is not impacted). Can anyone else duplicate this behavior, or is it unique to my setup/circumstances?
 
Joined
Dec 29, 2018
Messages
7
Lightroom Experience
Advanced
Lightroom Version
Cloud Service
Joined
Feb 1, 2010
Messages
13,728
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic
Are you sure that you included the correct photos? P4260338 is completely out of line compared to the first two, and LrC correctly states that it cannot be merged. The first two, however, do merge correctly and there's no issue with the Boundary Warp.

Panorama_Merge_Preview.png
 
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
Joined
Dec 29, 2018
Messages
7
Lightroom Experience
Advanced
Lightroom Version
Cloud Service
You could try incanting the traditional LR magic spell, resettting LR's preferences:
https://www.lightroomqueen.com/articles-page/how-do-i-reset-lightrooms-preferences/

LR sometimes soils its preferences file, and resetting it can fix all sorts of wonky behavior. That article explains how to restore the old preferences if resetting doesn't help.
Thanks so much John. I’ll assume it’s a glitch on my system and reset as you recommend. BTW, are you working on a PC or a Mac?
 
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
Hmm, I don't see any issue with the previews on my LR 11.4 / Windows 10:

1655332717971.png


The other projections are fine too.

Try setting Preferences > Performance > Use Graphics Processor to Off -- does the problem still occur? It would seem unlikely to cause this bug, but it's easy to rule out.
 
Joined
Dec 29, 2018
Messages
7
Lightroom Experience
Advanced
Lightroom Version
Cloud Service
I reset my Preferences (and Startup Preferences). I am using the Cylindrical projection option:
Screenshot 2022-06-15 18.19.20.png

The images all merge well, but at 36% boundary warp I get this:
Screenshot 2022-06-15 18.20.16.png


and at 85% it looks like this:
Screenshot 2022-06-15 18.20.31.png


And unfortunately, that's exactly what the merge output (and a sample .JPG export) look like.
I will try turning off the Graphics processor, as suggested.
 
Joined
Dec 29, 2018
Messages
7
Lightroom Experience
Advanced
Lightroom Version
Cloud Service
Turning off the Graphics Processor (it was at Auto) made no difference. This is not a critical error for me, I can just avoid using the Boundary Warp option, but it is odd.

Note: I tried the Spherical and Perspective options and the Boundary Warp option DOES WORK normally with them. It is only the Cylindrical projection that has an issue. For my panoramas, taken from one location rotating around my vertical axis, Cylindrical generally provides the best result, but Spherical is a good alternative.
 

GrahamP

Member
Joined
Mar 26, 2015
Messages
74
Lightroom Experience
Power User
Same issue, running Windows 10. It looks to me as if boundary warp works if there is an odd number of images, but does not work with an even number. Using spherical projection.
 
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
@rikenberry, I don't think you uploaded the right-most photo (369?) in your example. I only have three photos. If you upload that fourth photo, I'll try to exactly reproduce what you're seeing. That would make it much more likely Adobe will respond to a bug report.
 
Joined
Dec 29, 2018
Messages
7
Lightroom Experience
Advanced
Lightroom Version
Cloud Service
@rikenberry, I don't think you uploaded the right-most photo (369?) in your example. I only have three photos. If you upload that fourth photo, I'll try to exactly reproduce what you're seeing. That would make it much more likely Adobe will respond to a bug report.
John:

Thanks. I tried various versions of the panorama. The sample I uploaded here was actually 6 images, 366 through 371. They are all uploaded to the same Creative Cloud link now.
 
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
Joined
Feb 1, 2010
Messages
13,728
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic
John, I don't think it's just the Spherical projection which is faulty, in some of my tests it was also Cylindrical which caused a problem. But it's all very inconsistent....

Agree that's it's Windows only, though don't know if that includes Win11 or if it's Win10 only.
 
Joined
Feb 20, 2017
Messages
11
Location
Milton Keynes
Lightroom Experience
Advanced
Lightroom Version
It appears that the "Boundary Warp" option for creating Panoramas in Lightroom Classic is broken with the latest version. In my attempt to merge 6 images into a panorama, the other automatic options work (AutoCrop and Fill Edges), but selecting Boundary Warp under "Photo - Photo Merge - Panorama" now simply cuts off the top of the image. In the extreme case (100%) it leaves only about 5% of the image height (the width is not impacted). Can anyone else duplicate this behavior, or is it unique to my setup/circumstances?
Same problem, on Windows 10 PC, all up to date. Images will merge but Boundary Warp either does not work or produces a distorted image. :(
 
Joined
Feb 20, 2017
Messages
11
Location
Milton Keynes
Lightroom Experience
Advanced
Lightroom Version
John, I don't think it's just the Spherical projection which is faulty, in some of my tests it was also Cylindrical which caused a problem. But it's all very inconsistent....

Agree that's it's Windows only, though don't know if that includes Win11 or if it's Win10 only.
For me (Win 10 PC) all projections are affected. I too find the bug inconsistent. Attempts to merge distorted images from the 'preview screen' produce 'cannot merge images'. I can add that the images concerned all merge perfectly well in Photoshop but of course this does not include the 'Boundary Warp' option. On occasion LRC hangs altogether. I have tried purging my image cache but no help.
 
Joined
Apr 3, 2012
Messages
1,665
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
@rikenberry or @Eric1951, would either of you be able to file a bug report within a few days? Then each of us can add our own experience and sample photos and votes. That will make it much more likely that Adobe will prioritize the problem.

While I could file a bug report, I submit a great number of them, and I think Adobe is more likely to (initially) pay attention to bug reports filed from others.
 
Joined
Feb 1, 2010
Messages
13,728
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic
@rikenberry or @Eric1951, would either of you be able to file a bug report within a few days? Then each of us can add our own experience and sample photos and votes. That will make it much more likely that Adobe will prioritize the problem.

While I could file a bug report, I submit a great number of them, and I think Adobe is more likely to (initially) pay attention to bug reports filed from others.
John, I'm happy to file a bug report directly into the internal Adobe system, linking back to this thread and submitting a set of my own images which exhibit the problem. I can do that tomorrow morning if it would help.
 
Top