LR Update And Plugins

Sandyjas

Active Member
Joined
Feb 5, 2013
Messages
150
Location
Michigan
Lightroom Experience
Intermediate
Lightroom Version
#1
Lightroom Version
5
Operating System
Other (please note in thread)
I have iMac bought in 2013 running Mountain Lion 10.8,4. I now have Lightroom 5. In the future I will want to upgrade my OSX. When I upgrade Lightroom, whether it be to standalone 6.14 or suscription I wonder about this... I have one for sure plugin installed - ListView ver 1.68. I may install Search Replace Transfer ver 1.59 before the update of Lightroom. What will happen to the plugins after the update to Lightroom? Will these plugin versions work? Thank You for any help,

Sandy
 

Zenon

Active Member
Joined
Jan 13, 2017
Messages
887
Lightroom Experience
Advanced
Lightroom Version
Classic 7
#2
Mojove which is the latest version which supports 32 bit but that will be the last one. I haven't heard of anyones plug-ins failing to work yet. I'm running office 2008 and a B&W plug-in that is well over 10 years old with the latest version of PS. I 'd say your plug-in should work. Also developers are aware of what's coming down the road and they working on updates.
 

johnbeardy

Senior Member
Staff member
Moderator
Lightroom Guru
Joined
Oct 8, 2007
Messages
4,756
Location
London
Lightroom Experience
Power User
Lightroom Version
#3
After an LR update, you would normally expect plugins to work without any need to be updated. Those two, which are by me, do work fine.
 

Sandyjas

Active Member
Joined
Feb 5, 2013
Messages
150
Location
Michigan
Lightroom Experience
Intermediate
Lightroom Version
#4
After an LR update, you would normally expect plugins to work without any need to be updated. Those two, which are by me, do work fine.
Thank You both for the information. I'm looking into updating my OSX in the future and wondered about this.

Thank You,

Sandy
 

clee01l

Senior Member
Staff member
Moderator
Lightroom Guru
Joined
Jun 20, 2009
Messages
13,960
Location
Bellaire, TX USA
Lightroom Experience
Power User
Lightroom Version
Classic 7
#5
Depends... For the most part plugins work with all versions. Some developers (Jeffrey Freidl for example) require a new license key with each whole number update to LR (LR5 > LR6 >LR7 >LR8) John Beardsworth does not restrict Listview to a particular version.
 

Zenon

Active Member
Joined
Jan 13, 2017
Messages
887
Lightroom Experience
Advanced
Lightroom Version
Classic 7
#6
Jeffrey's are the only ones I have experienced this with. It is actually more of a donation. I have noticed he updates fairly often between the software updates. Then again I have only had his plug-ins for about 3 months.
 
Top