• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Are you using the cloud-based Lightroom apps for Windows, Mac, iOS, Android, Apple TV and Web? Then you'll love my new book, Adobe Lightroom - Edit Like a Pro!

    You'll learn how to use the Lightroom cloud ecosystem to organize, edit and share your photos. You'll also come to understand the thought processes used by professional photographers when they're editing their own photos, so you can transform your photos quickly and easily. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! Just the usual new cameras, lens profiles and bug fixes. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes. If you use a custom monitor profile on macOS, note that the Classic performance bug is not yet fixed.

LR to PS round trip

david.stegmann

New Member
Joined
Oct 19, 2019
Messages
5
Lightroom Version
4
Operating System
  1. macOS 10.15 Catalina
Is there a way around NOT loosing the layers when doing a round trip LR-PS-LR? When I work with Capture One and PS I can reopen the file from C1 and see again all layers. I did not find a way doing this with LR.
 
Joined
Jul 2, 2015
Messages
10,561
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
A round trip LR-PS-LR will not make you loose layers if you created these in Photoshop. What will make you loose these layers however is if you make a second round trip and do not choose ‘Edit Original’ for this second round trip. Remember that Lightroom does not support layers, so there is no way to see the layers while you are in Lightroom. But that does not mean they are lost.
 
Joined
Nov 27, 2013
Messages
1,429
Location
Queensland
Lightroom Experience
Intermediate
Lightroom Version
Classic
Lightroom v4 (The CLOUD Version)
Others are seeing the same problem! as is the OP David.Stegmann-
Read through this thread in the Adobe Community Forums for Lr:
 

david.stegmann

New Member
Joined
Oct 19, 2019
Messages
5
Thank you for all your replies. Yes, it is suggested this is a bug. As a workaround I do not return tu LR but safe the edited file in the cloud from PS. Then I just export a normal tiff and import in LR. When I need to make layer changes I go to PS and keep editing, safe and export again.
But of course this is complicated.
The Adobe tech that tried to solve the problem recognised it is a problem and installed the previous LR version. All was working with the layers ok. So yes, it’s a bug in v4 as far as I can tell. Surprised Adobe has not solved it yet.
 
Top