• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

LR not responding

Joined
Dec 4, 2017
Messages
13
Lightroom Experience
Intermediate
Lightroom Version
Lightroom Version
LRC 10.1
Operating System
  1. Windows 10
Since I upgraded to v10.1 a little while ago, my computer keeps freezing as soon as I try and do anything after I have loaded LR Classic. I run LR Classic on a Win10 computer with an NVIDIA Geoforce GTX 750Ti graphics card (latest drivers installed) and 16 GB RAM. I have resorted to reloading an earlier version (10.0) as a temporary fix. Are there problems with the latest release? Any other ideas? Many thanks.
 

sisipherr

New Member
Joined
Oct 18, 2021
Messages
1
I've had exactly this for ages, on my desktop and laptop.

I've got around this using the following...

Once you have tried to open LR and it comes up "not responding" right click on the LR icon in toolbar at bottom of screen and select the catalogue you want to use by left click on it, normally after 10-15 seconds LR is fully functional.

Stuart
I have struggled with this problem since I updated Lightroom in July, and I have lost so many hours to relaunching, restarting, reinstalling, and trying older versions of the software. After a week of blissful, uninterrupted workflow during which this solution worked instantly every single time, I came back here, found this thread again, and created an account just to say thank you. Bless you, Stu_Y, whoever you are, you just saved my career.
 
Top