• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • The February 2020 Lightroom updates are now available. Lightroom Classic has a brand new Defaults system, the ability to set a specific monitor for the secondary window and PSB format support. Lightroom (cloud-based service) has the ability to import presets on Android, DNG export and Split View support on iPadOS. The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.

LR 8.4.1 Crashing after launch in MacOS 10.13.6 - Need Help....

Joined
May 17, 2019
Messages
2
Lightroom Version
Unable to post as I can no longer launch LR....
Operating System
macOS 10.13 High Sierra
I can no longer launch LR without it crashing in about 25 seconds. I do not believe I've changed anything with my setup between it working and not working. My most recent change has been mounting a NAS system two weeks ago (planning to migrate images to it but haven't yet) but LR has been working since that change and before this problem. My system is an iMac, running 10.13.6 and I am running LR 8.4.1 It has 32G of RAM, an internal 3T drive where my catalog lives and my images are on attached USB drive. I have a single catalog that is about 1.2G in size covering are than 30k images (could be as high as 60k). I have tried the following:
1. Launched LR in safe mode (without reseting preferences)
2. Launched LR with Mac in safe mode
3. Deleted LR preferences file (.plist) and launched
4. I tried to edit the plist file to turn off GPU but could not figure out how to edit it (text shows up funny when using TextEditor even though viewing file via Finder looks correct)
5. Tried most of above with and without USB drive containing images attached to Mac.
6. Screamed and hollered at the screen but no luck....

What do you recommend as next attempt to fix it?
A. Try to launch LR in safe mode with preferences reset? (thinking that's the same a what I did in #3)
B. Upgrade LR to latest version and try it?
C. Continue trying to figure out how to edit .plist file to disable GPU (suggestions on how to do that welcomed)?
D. Call Adobe?
E. Something else??

Thanks,
Karl
 
Joined
May 17, 2019
Messages
2
Update on my situation. Victoria suggested trying to launch LR with new catalog using the option key. That worked with no issues so that narrowed the problem to my existing catalog. I restored an earlier version of the catalog from Time Machine (vs. a backup from LR) and I can now run LR with no problems. I'm glad I keep my catalog where Timemachine backs it up frequently. Feeling lucky it's resolved with no losses.
Karl
 
Top