Lr 5.6 lost the user presets for export and metadata and custom WB.

Not open for further replies.


Jan 29, 2013
Lightroom Experience
Lightroom Version
I had purchased the Lr 5 upgrade earlier this year but it wasn't until yesterday that I installed it.
The installation appeared to go well. The catalog was intact.

When I exported to Flickr the first and second times, Lr5 gave me a dialog box saying an internal error occurred, assertion failed. Then I got a dialog box saying Lr5 couldn't download comments from Flickr. But my photo was posted without problem at Flickr.

I googled and found some information about the internal error/assertion failure. One was that there could be an ownership problem. I went to ~/Library/Application Support/Adobe/Lightroom and assured the folder(s) all had my user login as being able to RW. All looked okay.
Then I went to Lr5 Preferences>Presets and ticked "Store presets with catalog."
Closed the app and relaunched the app. After this the internal error/assertion stuff didn't show up again when publishing to Flickr.

I also didn't have any problem exporting to PsCS4 via Command+Shift+E and choosing a user preset I had created back in Lr4.

So today I downloaded and installed the upgrade to Lr5.6.
It seemed to go well. Catalog intact.

But when I pressed Command+Shift+E, my user presets for exporting to PsCS4 were gone. And my metadata presets for importing and having the creator added to the metadata were gone. I had one for my name and one for my wife's name. And I had a couple white balance presets for the Develop module for my infra-red captures. Those WB presets were created outside of Lr so I think I can hunt them down and make them available in Lr5.6.

I searched in ~/Library/Adobe and subfolders and other folders, but couldn't find the presets that had been created in Lr4 and had been preserved in Lr5.0. I even searched in my Time Machine back ups but couldn't find the user presets from then.

So I've had to create new presets.

I'm posting this not to ask for help, but to relay my experience with upgrading to Lr5.0 and how I think the internal error/assertion problem was solved.

If anyone has a way to find the previous user presets and bring them into Lr5.6, please feel free to post here so others might not have to recreate theirs.

What I've done since recreating my export user presets and metadata user presets is copy them onto a external hard drive. Any time from here on out that I create a user preset in any module, I'm going to save that .lrtemplate file onto another drive. And when I recreate the new white balance presets for the Develop module, I'll hunt them down and save them elsewhere too.

My advice to anyone about to upgrade to a newer version of Lr, is to go to ~/Pictures/Lightroom/Lightroom Settings/ and go through all the Preset and Actions folders to copy to another drive or another folder on the hard drive, any User Presets prior to installing an upgrade.
In the midst of your lengthy post is the line 'Then I went to Lr5 Preferences>Presets and ticked "Store presets with catalog."' could I ask why? And secondly, what happens if you uncheck that option, do all your presets return?
In the midst of your lengthy post is the line 'Then I went to Lr5 Preferences>Presets and ticked "Store presets with catalog."' could I ask why? And secondly, what happens if you uncheck that option, do all your presets return?
Jim, I went there because that was one of the googled solutions I had found. I would never have suspected that ticking it would have changed a behaviour that would make a difference for the internal error/asssertion failure. But it appears to have fixed it.
Ticking it didn't make my export presets disappear. They were still present until upgrading to Lr5.6. After ticking "Store presets with catalog" I was able to export to PsCS4 with my user presets and then publish to Flickr without getting the internal error stuff.
I lost my export presets after upgrading from Lr5.0 to 5.6.
I hope that the sequence makes sense. So therefore I haven't gone back to untick that option in preferences. Although I might because I've an enquiring mind. But might not because the same mind doesn't want to rock a steady boat...
There is a Global location for LR presets. When the "Store presets with catalog." is checked, a folder in a local location is created in the same folder with the LR Catalog. It is called "Lightroom Settings". Checking the box does not move the global presets, it just creates the folder and subfolders for future presets. Your global folder is (and still is) "/Users/[userName]/Library/Application Support/Adobe/Lightroom". In it you will find folders with names like "Metadata Presets" These will contain all of your missing presets. You can either copy the relevant folders found in "/Users/[userName]/Library/Application Support/Adobe/Lightroom" to the folder named "Lightroom Settings" or you can uncheck the checkbox labeled "Store presets with catalog."
For a more detailed explanation of the "Store Presets with this Catalog" option, see this post.
Last edited by a moderator:
For a more detailed explanation of the "Store Presets with this Catalog" option, see this post.
Jim, I can't see how or why checking "Store presets with Catalog" at all helped with my situation of the internal error/assertion failure. It shouldn't have done a thing to have helped that. Could it be coincidence? A thing which appeared related due to a nearness in time, but yet not related?
And then later when I upgraded from Lr5.0 to 5.6, could having the Store presets etc option ticked cause Lr5.6 not to find my previous presets?

And thank you Cletus for the path to the Lightroom folder in App support. I went there after upgrading to Lr5.6 from 5.0 and there were no user presets in any folders. There are now that I recreated a couple. And I've copied them to a separate drive.

What I'm going to do now, is go back to Lr5.6 preferences and untick the option for Storing, etc.
Last edited by a moderator:
I unticked that option. Closed Lr5.6. Reopened. Published a photo to flickr. No internal error/assertion failure.
My old user presets for exporting were back. But the one newly created was gone.

I navigated ~/Library/Application Support/Adobe/Lightroom/Export Presets/User Presets and found my old .lrtemplates.
Cletus, I'm not sure if I had navigated to that folder after upgrading to Lr5.6. I had when I had the internal error problem, but I only went as far as folder level to assure the folders had the proper permissions. I suspect I hadn't gone there after upgrading to 5.6. I should have.

After finding that my older templates were back and finding them in Library/App Support, I navigated to ~/Pictures/Lightroom/Lightroom Settings/Export Presets/User Presets and found my newly created template and dragged it from there to the App Support User Presets.
That new .lrtemplate now shows up along with my older ones when I press Command+Shift+E.

Thanks Jim for the education regarding that option of Store Presets with Catalog.

Which leaves me wondering, what the heck was going on with the internal error/assertion failure stuff that was happening with the upgrade from Lr4.4 to 5.0, prior to the upgrade to 5.6.

A self-limiting problem that fixed itself coincidental with just looking at my permissions for folders or coincidental to ticking the Store presets with Catalog?

Googling had found quite a bit of discussion regarding that problem with a few different upgrades of Lr. It had been happening with 3.0 and 4.0. Most of the time the problem had been fixed with fixing permissions. All my folders seemed to have the proper permissions. And one responder had made the suggestion for ticking the Storing presets option. But that doesn't make sense in light of your information Jim about what that option provides.

Well, I hope someone finds all this discussion helpful sometime.

Jim, Cletus, thank you.
Last edited:
John, I really have no idea what cured your assertion failure, as you say most often it's a permissions issue....but I can't see how checking (and subsequently unchecking) that option would have cleared the problem.

But glad you are back up and running.
Not open for further replies.