• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again. Just some small tweaks as well as cameras/lenses and bugs! See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Import LR 10 & 11 and Windows 10: problem with PC memory management?

Joined
Jul 27, 2019
Messages
10
Lightroom Experience
Intermediate
Lightroom Version
Classic
Lightroom Version
Lightroom Classic version 10.x and 11.0
Operating System
  1. Windows 10
Has somebody the same problem and knows what to do? I have it with LR classic 10 and now and worse with LR 11 (MS Windows 10).
My PC has a AMD 24 core cpu and 128GB ram. I import raw files - e.g. more than 150 - and let LR create 1:1 previews simultaneously. During the import and especially while creating the previews LR allocates around 60-80GB ram and the workload of all(!) 24 cores is up to 95%. Up to this point everything is absolutely ok and the import is runnig fast.
Now after the import but in the same LR session the amount of allocated memory is not reduced- imho not a normal behaviour - and the responsiveness of zoom in and out is very slow (LR11).
When I close LR normally, further two additional versions of the same problem show up. The Windows task manager shows still the running LR process with a cpu workload around 2-5% (this is a lot on this machine) and no(!) disk activity while the allocated memory is reduced in decrements of some hundred MB. This process can take up to some minutes. I am pretty sure, that there are no LR data are saved or written to disk. When there remains no allocated memory the LR process is closed and only then I can restart LR, that means several minutes after "closing" it. The worse variant of the problem- which shows up now in LR11 - is, that the process of memory deallocation gets stuck. I have to kill it before it is possible to restart LR.
 
Joined
Nov 5, 2017
Messages
1,505
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
Joined
Apr 3, 2012
Messages
1,417
Location
Bay Area, California, USA
Lightroom Experience
Power User
Lightroom Version
Classic
Some educated guesses: You've got a machine much larger than the typical desktop, with 24 cores and 128 GB memory. It's very possible Adobe hasn't tested on such a large configuration. That it takes so long for LR to deallocate the 80 GB of memory it was using may be due to a limitation of Windows rather than LR. Allocating and deallocating virtual memory has never been "free", and it wouldn't surprise me if the time spent during deallocation is due to Windows, not LR proper. So if true, LR might be better tuned to limit the amount of virtual memory it allocates.

But I agree with Paul, post a bug report.
 
Top