• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 17 August 2022 It's Lightroom update time again and there's a couple of minor improvements as well as new cameras, lenses and bug fixes! See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Library module Lost Library Folder

Chessman

Member
Joined
Jul 30, 2018
Messages
36
Lightroom Experience
Intermediate
Lightroom Version
6.x
Lightroom Version
Lightroom Classic 11.4
Operating System
  1. macOS 12 Monterey
I've lost my Scotland 2021 folder in LR Classic Library but the folder and all the photos are in my iMac Finder. I have it named as A-Scotland 2021 so it appeared at the top of my Library list for quick access to edit. I completed all the editing last year. I've just noticed it missing as I moved my Oystercatcher photos from Scotland 2022 folder into my Birds/Oystercatcher folder. My iMac is Monterey 12.4.

All my search results are about connecting Library photos with a ? to the Finder (hard drive) folder not the reverse. Before I start the task of re-importing from Finder via the desktop and possibly losing my editing and my psd files is there another way. ? If I'd accidently deleted them from Library they woudn't still be in Finder so I don't know what's happened. It's as though I'd somehow clicked on 'Remove' rather than 'Delete from Disk' but I wouldn't do that.

Thanks.
 
Joined
Nov 27, 2013
Messages
1,939
Location
Queensland
Lightroom Experience
Intermediate
Lightroom Version
Classic
First suggestion- If the previews of the images are still showing in the LrC library (with the ! badge)- Or Folders show the ? icon-
DO NOT RE-IMPORT PHOTOS! I repeat DO NOT IMPORT PHOTOS.
In fact if you try to re-import you should get the error message that the 'photos already exist in the Catalog'.
It is better to re-link the Catalog to the changed location of the folder/files.
MISSING FILES & FOLDERS (Lightroom Queen)
MISSING FILES AND FOLDERS-(Computer Darkroom)
"I've lost my Scotland 2021 folder.....I have it named as A-Scotland 2021" If you renamed it with Mac Finder, then that explains the missing folder in the catalog.
Any changes made with Finder (even changing a letter: lower-case to upper-case) will lose the link with the Catalog and result in 'Missing' Folders/files.

"connecting Library photos with a ? to the Finder (hard drive) folder not the reverse."
The "Reverse" is taking the action to restore (using Finder) the Folders/Files back to the exact location and names where the Catalog believes them to be.
 

Chessman

Member
Joined
Jul 30, 2018
Messages
36
Lightroom Experience
Intermediate
Lightroom Version
6.x
Thank you for your response.

I took a look at the first link 'Missing Files and Folders' and it's about files with that ? on them. The second link likewise but an exclamation mark.In both cases the photos are there but not linked. My issue is that the folder isn't there. I wondered if I would be able to insert as screen grab..the best way to show the problem and I can. It would have helped you see the problem so apologies for not thinking of that yesterday.

What I did read in that second link you included is that any external disk that has been unplugged will cause a problem .

Last week I opened LR6 to find every folder in the Library had a ? mark. I then saw that the L3-4-6 icon on the desktop had gone. That's the external backup disk for LR6 and also has on it my LR 3 &4 photos. I no longer have the App LR3 &4 just the photos and Finder folders. The cable must have loosened so I pushed it back in and everything came back apart from the first folder A-Scotland 2021.

The A-Scotland2021 should be the first folder in the list..ie above Aircraft .I've scrolled through all the 1134 LR6 photos and Scotland 2021 is not there

Screenshot 2022-06-29 at 11.53.22.png


Here it is in Finder with all the photos inside intact.


Screenshot 2022-06-29 at 11.38.56.png


Hope this all helps. In that first link I see it says that if the folder in Library is completely missing then the best way is to get it back in from the backup. Is this what I'll have to do ? The Finder /backup A-Scotland 2021 folder is there. I backup after deleting all unwanted photos and the editing is done.

I'll still be left not knowing why every other folder returned after I plugged the Backup disk cable in properly apart from the A-Scotland folder.

Thank you again.

John
 

Attachments

  • Screenshot 2022-06-29 at 11.37.29.png
    Screenshot 2022-06-29 at 11.37.29.png
    70.9 KB · Views: 17
Joined
Nov 27, 2013
Messages
1,939
Location
Queensland
Lightroom Experience
Intermediate
Lightroom Version
Classic
If you have jumped in and restored a total catalog from a backup- then that's OK and you will need to re-do the work you did since that backup was made.

If you have NOT yet restored from a backup- there is a way to restore ONLY the missing folder from a backup catalog. It involves 'extracting' the {A Scotland 2021} folder from the backup by [Export as a Catalog] and then use [Import from another Catalog] to re-unite your master catalog with the extracted catalog (containing only {A Scotland...} ).
Explained in this blog article from Victoria-
RESTORE PARTIAL from backup catalog?
 

Chessman

Member
Joined
Jul 30, 2018
Messages
36
Lightroom Experience
Intermediate
Lightroom Version
6.x
That's brilliant..I was going to use the backup later today but will now follow the instructions in the link.

Many thanks for taking the trouble to get back to me. Much appreciated :thumbsup:
 

Chessman

Member
Joined
Jul 30, 2018
Messages
36
Lightroom Experience
Intermediate
Lightroom Version
6.x
If you have jumped in and restored a total catalog from a backup- then that's OK and you will need to re-do the work you did since that backup was made.

If you have NOT yet restored from a backup- there is a way to restore ONLY the missing folder from a backup catalog. It involves 'extracting' the {A Scotland 2021} folder from the backup by [Export as a Catalog] and then use [Import from another Catalog] to re-unite your master catalog with the extracted catalog (containing only {A Scotland...} ).
Explained in this blog article from Victoria-
RESTORE PARTIAL from backup catalog?


Hi..It never rains but pours, as they say:)

It turns out that my WD 1TB backup external drive had failed. There was nothing on it. It wouldn't respond to Disk Repair or even be wiped clean to start again,maybe. I need a new one. I only had the import option left. I'll outline what I did as it might help others.

I re-created the lost folder 'A-Scotland 2021' folder name in Library.

I tested two photos,an original and the edited version and imported them into LR from one of the Finder Scotland 2021 subfolders. They went in ok. I then took the first subfolder dragged and dropped it into LR. In the import window was, of course, A-Scotland 2021 and all the subfolders so I just selected the sub-folder name they had come from and clicked import. It went without hitch. I then imported them subfolder by subfolder. All the photos are back in Library and the edited ones retained the edits and also the editing history.

Seems I'll never know why I lost the' A-Scotland 2021' folder in Library but all's well that ends well, as they say.
 
Top