• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 25 June 2024 It's Lightroom update time again! See What’s New in Lightroom Classic 13.4, Mobile & Desktop (June 2024)? for the bug fixes and new lens profiles. Warning... this is a minor dot release and does NOT fix some of the bugs introduced in 13.3, so if you reverted to 13.2 due to bugs (e.g. sync issues), we'd suggest you stay there for now.

Limited support for non-English characters?

Status
Not open for further replies.

gYab61zH

Active Member
Joined
Aug 12, 2011
Messages
265
Location
Germany
Lightroom Experience
Advanced
Lightroom Version
Lightroom Version Number
12.3
Operating System
  1. macOS 13 Ventura
I am shocked and dismayed to find that LR does not appear to fully support (the display of) the Unicode character set (Roman script). I am preparing a Book on Turkey at the moment and although LR allows me to enter certain characters like ǧ, it does not display them in the Book module, so the place name "Boǧazkale" becomes "Bo☒azkale." Is there anything that can be done about this?
 
My experience suggests that you need the native language version of MacOS and perhaps the Native Language version of LrC. If you have the native language version of MacOS and the Native Turkish Keyboard (F-Keyboard) showing the characters that you need, I don't think you will have this issue. I've never used the Book Module with non English Language keyboard or words.
Mostly, I have seen this issue in viewing text in non unicode supported apps and operating systems. Windows Browsers are notorious for poorly displaying Unicode text that shows properly on a Mac.
 
Last edited:
What font are you using for the text box in Book, and what happens if you use a different one?

I tried pasting from your post and the ǧ character seemed OK in book. This is on an Mac set up for UK English.
 

Attachments

  • Screenshot 2023-06-03 at 13.20.32.png
    Screenshot 2023-06-03 at 13.20.32.png
    1 MB · Views: 70
What happens if you use a different font in Book?

I tried pasting from your post and the ǧ character seemed OK in book. This is on an Mac set up for UK English.

I think this is probably the solution. MacOS and Windows displays the “x-box” when ever the Unicode character does not exist in the font file.

(Not taking a political position are we John???)

Sent from my iPad using Tapatalk
 
If this is the case, remember that you can put the book into its grid view and then use Edit > Select All Text Cells to select text and quickly change the font on every page.
 
Last edited:
(Not taking a political position are we John???)
Well.... So for balance here's a royal fan waiting for the Coronation!
 

Attachments

  • DSCF6563.jpg
    DSCF6563.jpg
    238.2 KB · Views: 93
Hi thanks for the replies. I too can see the problematic characters without a problem in Library or Edit mode, it is when I switch to the Book module that they fail to display. In the book module I use MyriadPro, but "caption" and "title" also fail to display the characters. I see no other font options in the Book module.
 
although LR allows me to enter certain characters like ǧ, it does not display them in the Book module, so the place name "Boǧazkale" becomes "Bo☒azkale."

Looks like you're having issues with Unicode fallback fonts on your computer. I'm not an expert on Mac Unicode fonts, but I have some experience, being last tortured in Unicode font hell re-implementing the 16-language shortcut tables for Lightroom Queen with my Any Shortcut plugin.

Experimenting with ǧ on my LR 12.3 / Mac OS 13.4, it's always displayed regardless of which font is selected, albeit in a fallback font if the selected font doesn't contain that character. For example:

1685803853581.png


A google for "mac fallback fonts" shows this is a poorly documented, poorly understood issue at the Mac OS level, and there is nothing documenting how LR handles fallback fonts and whether it relies entirely on Mac OS or has its own mechanism layered on top. This article sketchily suggests that the default fallback fonts on Mac OS depend on the region and list of preferred languages configured for your system:
https://raphlinus.github.io/rust/skribo/text/2019/04/04/font-fallback.html

So to make progress on this issue, we'll have to play twenty questions, with precise answers required. This will let us reproduce the problem and identify a workaround:

1. In which exact page field in Book are you entering the character?

2. What is the font (e.g. Blood of Dracula) and weight/style (Regular, Bold Italic, ...) selected in the Type panel for that field?

3. Which language is selected in LR's Settings > Preferences > General > Language?

4. Post a screenshot of your Mac's System Settings > General > Language & Region panel, e.g.

1685806030136.png
 
You have to select the text box (using mouse or that menu option), then the fonts become available.
 
Looks like you're having issues with Unicode fallback fonts on your computer. I'm not an expert on Mac Unicode fonts, but I have some experience, being last tortured in Unicode font hell re-implementing the 16-language shortcut tables for Lightroom Queen with my Any Shortcut plugin.

Experimenting with ǧ on my LR 12.3 / Mac OS 13.4, it's always displayed regardless of which font is selected, albeit in a fallback font if the selected font doesn't contain that character. For example:

View attachment 21020

A google for "mac fallback fonts" shows this is a poorly documented, poorly understood issue at the Mac OS level, and there is nothing documenting how LR handles fallback fonts and whether it relies entirely on Mac OS or has its own mechanism layered on top. This article sketchily suggests that the default fallback fonts on Mac OS depend on the region and list of preferred languages configured for your system:
https://raphlinus.github.io/rust/skribo/text/2019/04/04/font-fallback.html

So to make progress on this issue, we'll have to play twenty questions, with precise answers required. This will let us reproduce the problem and identify a workaround:

1. In which exact page field in Book are you entering the character?
Usually the Caption field, but I also use the Page field and the Photo Description box.
2. What is the font (e.g. Blood of Dracula) and weight/style (Regular, Bold Italic, ...) selected in the Type panel for that field?
MyriadPro Regular
3. Which language is selected in LR's Settings > Preferences > General > Language?
English
4. Post a screenshot of your Mac's System Settings > General > Language & Region panel, e.g.
Screenshot 2023-06-03 at 19.02.07.png
 
You have to select the text box (using mouse or that menu option), then the fonts become available.
I am not sure what text box you mean? Do you mean the one associated with an image in the Book module? If so, I can select it but it still only shows me the "fonts" I mentioned.
 
I see the same problem with Myriad Pro:
1685846736327.png


and with other fonts that don't have a glyph for ǧ. The font fallback mechanism isn't working correctly.

A workaround is to select all the text in the field, switch to a font that supports the character (e.g. Helvetica), then switch back to Myriad Pro. Then a fallback font is used to display the character:
1685847845443.png


But I don't think you'll be satisfied with the results, since the characters like ǧ simply aren't supported by Myriad Pro, and the fallback font will display the characters in a different font.

I think you'll be more pleased with the results if you choose a font that supports the desired characters (e.g. Helvetica).

I observe the same behavior on Windows 11, which leads me to think that this is a bug in LR rather than the operating-system font libraries. I filed a bug report here:
https://community.adobe.com/t5/ligh...-not-supported-by-current-font/idi-p/13839897

But I very much doubt Adobe will ever fix the bug -- there are lots of longstanding bugs in the Book module, and Adobe has deprioritized support for problems outside the Develop module. Even if they fixed the bug, you wouldn't be happy with the results, I think.
 

Attachments

  • 1685847387517.png
    1685847387517.png
    14.5 KB · Views: 77
  • 1685846927332.png
    1685846927332.png
    16.5 KB · Views: 78
  • 1685846788639.png
    1685846788639.png
    16.7 KB · Views: 62
Thank you all very much. Changing the font solved the problem, although by no means every font supports all the characters. Myriad Pro Web does most things but I ultimately switched to Helvetica Neue, which appears to provide excellent coverage. I would also like to thank you for the suggestion on how to change all text fields. That worked like a dream, even if I have to go through everything to adjust things.

PS. I guess I got into a bit of a rut and it never occurred to me to look beyond the Text Style Preset for fonts. I restored Default Presets and then discovered access to all the installed font on the Mac!

Screenshot 2023-06-04 at 12.19.36.png
 
Status
Not open for further replies.
Back
Top