• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The December 2019 Lightroom updates are now available. Lightroom Classic is just bug fixes and new cameras in this release, but it fixes a whole load of macOS Catalina issues.
    Lightroom (cloud-based service) has export options and direct import on iOS and the ability to contribute photos to someone else's account from the desktop/mobile apps.
    The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Lightroom Thinks photos are under 2 different drives

Dayna

New Member
Joined
Feb 2, 2019
Messages
2
Lightroom Experience
Intermediate
Lightroom Version
Lightroom Version
Lightroom Classic Version 8.1
Operating System
Windows 10
Hi all - Not sure what I did but under folders, the drive I always use (DM-Primary) , and the drive that has all of my photos is only showing 56 of my 17k+ photos and then underneath, there is an "E" drive with all of my photos folder. There is no "E" drive on my computer anywhere and when I right click to find the missing folder (Which is on my "D" drive) I am getting this error message: an internal error has occurred : ?:0 attempt to index field "?" (a nil value) Here is a screen shot of my panel - any help would be greatly appreciated!
Picture1.png
 

Dayna

New Member
Joined
Feb 2, 2019
Messages
2
Lightroom Experience
Intermediate
Lightroom Version
I am right clicking on my photos folder with the? Under the E drive and it’s giving me options and I am selecting “find missing photos” and then I get that error message… Thanks
 
Joined
Feb 1, 2010
Messages
11,825
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
I assume you mean you select "Find Missing Folder", yes? And does that error message appear immediately, or do you see a file browser window open first (which is what should happen)?
Do you have a reasonably up-to-date catalog backup? Reason for asking is I suspect there's something wrong with your current catalog, as I have never known that error message to appear when just trying to select the Find Missing Folders message.
 
Joined
May 9, 2015
Messages
398
Lightroom Experience
Power User
I tend to agree with Jim. One other thing you may want to change your LR backup preference to "every time Lightroom Exits" and then close LR. when the backup dialog pops up, check both the "test integrity" and "optimize catalog" boxes and let LR perform those operations and take a backup.
 
Top