• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! There's new Presets in all versions, Super Resolution on the desktop, new Sharing options and more. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Lightroom Not Responding

Joined
Jul 21, 2021
Messages
2
Lightroom Version
10.3
Operating System
  1. Windows 10
Hi everyone - I've just joined up, wish I'd discovered Lightroom Queen earlier!

I've just started having a Lightroom is 'not responding' problem (v10.3) - I thought it was my 5 year old laptop with just 12Gb of RAM finally telling it was time to upgrade, but after reading through another thread about similar issues with v10.1, I'm wondering whether it is in fact Lightroom rather than my laptop that's the problem. I've tried rolling back to v10 but the same thing happens, so now I'm back to 10.3 again - I can't get past frozen screen and 'not responding' - is this still an ongoing issue for others?

Thank you, Michelle
 
Joined
Nov 5, 2017
Messages
1,263
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
Hi Michelle, and welcome to the forums!

Lightroom is certainly happier with more memory (16GB is recommended) but it should still load and run, the minimum is 8GB. And while there are always different issues for different people, no, generally LrC10.x runs!

One simple solution to try is to reset the Preference file (if it gets corrupted it can cause odd things, and it's read when you first open Lightroom) - blog explains how:

 
Top