Lightroom no longer finding my images on external hard drive resolved

Status
Not open for further replies.

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x
Hi there !

I'm a newbie with LR4 on my iMac,using an external hard drive to store my photos from 2011-2015.

All has been well with me editing photos stored on the hard drive only a few days ago. Today I have gone to do the same and Lightroom has Question marks against all my folders on the external drive. When I open a folder, I get the message about the file being offline or missing. I cannot understand why this has suddenly happened and I am desperate to find a resolution.
The images are definitely still on the external drive. I am loathe to press any buttons until I know the correct method, as I don't want to make things worse.
Here's hoping.....
Amanda
 
Joined
Feb 1, 2010
Messages
13,729
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Classic
Hi, welcome to the forum.

If all the folders have questions marks, it's likely that for some reason the hard drive has not been detected by Lightroom (unless you've renamed either the hard drive or the parent folder of your photo library?). Is the drive name greyed out? If so, try rebooting the system, check to make sure the drive is mounted correctly, then start Lightroom again.
 
Joined
Jul 2, 2015
Messages
12,340
Location
Netherlands
Lightroom Experience
Power User
If the images are suddenly shown as missing, you probably moved them outside of Lightroom, or renamed their folder outside of Lightroom, or renamed the entire external disk.

To solve this, right-click on the top folder in the Lightroom folder panel. A contextual menu comes up. Choose 'Find Missing Folder'. Navigate to the correct folder on the external disk in the dialog that follows and select that folder. That's it. Lightroom now knows that folder again. You may have to repeat this for some other folders if you do not have a folder hierarchy with only one top folder.
 

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x
Hi, welcome to the forum.

If all the folders have questions marks, it's likely that for some reason the hard drive has not been detected by Lightroom (unless you've renamed either the hard drive or the parent folder of your photo library?). Is the drive name greyed out? If so, try rebooting the system, check to make sure the drive is mounted correctly, then start Lightroom again.
Hi Jim - thanks - My WD passport isn't greyed out and it has a green light on to its left.
I haven't renamed anything -it's all exactly as it was 48 hours ago ...?!
 

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x
If the images are suddenly shown as missing, you probably moved them outside of Lightroom, or renamed their folder outside of Lightroom, or renamed the entire external disk.

To solve this, right-click on the top folder in the Lightroom folder panel. A contextual menu comes up. Choose 'Find Missing Folder'. Navigate to the correct folder on the external disk in the dialog that follows and select that folder. That's it. Lightroom now knows that folder again. You may have to repeat this for some other folders if you do not have a folder hierarchy with only one top folder.
T
 

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x
ThanksJohan !

I haven't renamed or moved anything -and I was only working on a few images. They are all missing.
 

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x
ThanksJohan !

I haven't renamed or moved anything -and I was only working on a few images. They are all missing.
I've done a restart as suggested by Jim - and nothing changed.
I've now followed your instructions and my 4 folders that were underneath the parent folder i.e. 2012,2013,2014 & 2015 have completely disappeared. Only the top folder remains - please help !
 

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x
I've done a restart as suggested by Jim - and nothing changed.
I've now followed your instructions and my 4 folders that were underneath the parent folder i.e. 2012,2013,2014 & 2015 have completely disappeared. Only the top folder remains - please help !
 

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x
I've done a restart as suggested by Jim - and nothing changed.
I've now followed your instructions and my 4 folders that were underneath the parent folder i.e. 2012,2013,2014 & 2015 have completely disappeared. Only the top folder remains - please help !
ThanksJohan !

I haven't renamed or moved anything -and I was only working on a few images. They are all missing.
Hi Jim - thanks - My WD passport isn't greyed out and it has a green light on to its left.
I haven't renamed anything -it's all exactly as it was 48 hours ago ...?!
Hi Jim - thanks - My WD passport isn't greyed out and it has a green light on to its left.
I haven't renamed anything -it's all exactly as it was 48 hours ago ...?!
 

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x

After looking at the images on the hard drive, the iMac froze on Photoshop elements, so I did a forced quit and restart.
The missing folders seem to have returned and the photos also.
I cannot promise to understand, it may be that your tip helped Johan, but perhaps I also needed to restart the machine after I'd done it ? You didn't advise that - but it's the only thing that I can think fixed it. Other choice is that the iMac, Lightroom, or the HD were playing up and another restart solved it ?!
Thanks
 
Last edited:

Amanda Clowe

New Member
Joined
Feb 3, 2017
Messages
14
Lightroom Experience
Beginner
Lightroom Version
4.x
You may be correct - it was rather random !
I will do a further back up to the cloud in case the HD is dodgy.
Thanks for your help.
How do I close a query ?
Amanda
 
Joined
Jun 20, 2009
Messages
19,316
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
How do I close a query ?
Simply stop posting. Unless closed by the admins, Queries remain open for future comments Perhaps some one will see an old post and having the same problem ask a different related question. If you like, you can amend the Title in the original post with the word "Resolved:"
 
Status
Not open for further replies.
Top