• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The August 2019 Lightroom updates are now available. Lightroom Classic includes advanced GPU support, batch HDR/pano merge and more. Lightroom (cloud-based service) has deleted photos on the desktop/mobile apps, as well as video support and batch metadata editing on Android. The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Lightroom Library locked in Compare View

Joined
May 17, 2019
Messages
7
Lightroom Version
Lightroom Classic version: 8.4
Operating System
macOS 10.11 El Capitan
I'm unable to move from compare view in Lightroom Classic to the grid view. I followed the suggested troubleshooting suggestion listed on this website but to no avail. When I exit Lightroom and turn it back on it remains in the compare view and will not allow me to shift to grid view. Would appreciate anyone's experience to resolve this issue.
 
Joined
Sep 29, 2007
Messages
21,505
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Hi Saxriff1, welcome to the forum!

What happens if you try to go to, for example, the Develop module? And how long have you been using 8.4 on El Capitan? It's not officially supported on that OS, so I'm wondering if that's part of the problem.
 
Joined
May 17, 2019
Messages
7
Hi Saxriff1, welcome to the forum!

What happens if you try to go to, for example, the Develop module? And how long have you been using 8.4 on El Capitan? It's not officially supported on that OS, so I'm wondering if that's part of the problem.
When I go to the Develop module, one of the images in the compare mode shows up. I've been using 4.4 El Capitan since it updated the software and it hadn't been a problem.
 
Joined
Sep 29, 2007
Messages
21,505
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
It's possible that they've tightened up the restrictions recently. However, since the rest seems to be working, let's keep at it.

From Develop, does it let you hit the G key to go back to Grid? Or what happens when you click G?
 
Joined
May 17, 2019
Messages
7
It's possible that they've tightened up the restrictions recently. However, since the rest seems to be working, let's keep at it.

From Develop, does it let you hit the G key to go back to Grid? Or what happens when you click G?
I tried that, however, it didn't allow me to go back to Grid. Actually, when I press the G key or when I move the curser to Grid and press nothing happens.
 
Joined
Sep 29, 2007
Messages
21,505
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
When did it start? Like, what were you doing before it started? Did you perhaps run a Lightroom update or something like that?

And can you go to Help menu > System Info and paste the top section of text please? That might offer some clues.

Is there a particular reason you're still on El Capitan? Now's the ideal time to upgrade to Mojave, with Catalina due out shortly. We're shooting in the dark since El Capitan is unsupported and was supposed to be blocked installing.
 
Joined
Sep 29, 2007
Messages
21,505
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Ah good, that helps. Ok, what troubleshooting steps have you tried so far? Did you try resetting preferences? And what happened just before this broke?
 
Joined
May 17, 2019
Messages
7
Lightroom Classic version: 8.4 [ 201908011719-03751b60 ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.14.6 [18G87]
Application architecture: x64
Logical processor count: 8
Processor speed: 2.3 GHz
Built-in memory: 8,192.0 MB
Real memory available to Lightroom: 8,192.0 MB
Real memory used by Lightroom: 1,315.7 MB (16.0%)
Virtual memory used by Lightroom: 4,306.4 MB
Memory cache size: 80.1MB
Internal Camera Raw version: 11.4 [ 273 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX
Camera Raw virtual memory: 603MB / 4095MB (14%)
Camera Raw real memory: 604MB / 8192MB (7%)
Displays: 1) 2880x1800

Graphics Processor Info:
Metal: NVIDIA GeForce GT 650M
 
Joined
Sep 29, 2007
Messages
21,505
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Joined
May 17, 2019
Messages
7
To reset preferences, hold down Alt/Opt-Shift as you start Lightroom, and you'll get a dialog box to reset. So if I do this is there some suggestions which preference to choose in each category
 
Joined
Sep 29, 2007
Messages
21,505
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
In the dialog that comes up when you follow those instructions, there's nothing to set. Just say yes. That'll wipe out the preferences file, which can sometimes become corrupted, and set the preferences back to their defaults.
 
Top