• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! There's new Presets in all versions, Super Resolution on the desktop, new Sharing options and more. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Lightroom Classic Syncing issue

Nooboy

New Member
Joined
Jul 3, 2019
Messages
8
Lightroom Version
9.4
Operating System
  1. Windows 10
Hi, I've got an issue with some images sync status stuck at 'Uploading to Lightroom'. The images are showing in Lightroom on the web, so it appears they have uploaded, but they're still showing in the upload queue in 'Preferences>Lightroom Sync', but they're not showing an error. Also the blue 'sync-in-progress' circle is ever present on the sync status cloud icon in the TRH corner. I've tried resetting the sync folder etc to no avail, I've tried renaming the files too. If I remove the offending file/s from the sync folder in LR Classic the problem stops, but obviously this defeats the object of being able to sync files. The files I'm having sync problems with are originating from LR mobile on my smartphone and the sync problem is in LR Classic desktop 9.4. I read somewhere that there had been a sync issue between LR Mobile and LR Classic but this had supposedly been fixed in the last update. Could anyone please shed any light on this? Many thanks for reading my post
 

gs

New Member
Joined
Sep 7, 2020
Messages
1
Location
Germany
Lightroom Experience
Advanced
Lightroom Version
Classic
I have the same issue since updating to 9.4 a few days ago.

There are continiously 23 photos being synced but in fact they are already in the cloud. No error messages in the preferences panel "LR Sync".
 

davidlplume

New Member
Joined
Sep 8, 2020
Messages
4
I too have the same issue. I have been putting keywords into previously uploaded photos. My catelog has 60,000+ photos of which 52,000 are uploaded.

For several days I have had 472 photos not syncing. I have removed a folder with 319 photos as I can see from the sync activity list that it was the folder showing most often. The number of photos dropped to 89 then, in a couple of minutes, jumped to 272 and has stuck again. It looks like a buffer has been filled and if I clear items from the sync it just goes and finds more.

Help please.
 

davidlplume

New Member
Joined
Sep 8, 2020
Messages
4
Sorry, extension to my post above. The photos that are stuck in the queue to sync have already been updated and are showing with all keyword updates in Lightroom Mobile and through the website.
 
Joined
Jun 20, 2009
Messages
17,852
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
In another thread, the author reverted back to v9.3 and the problem went away only to return when v9.3 was upgrades again to v9.4

Here is the Bug report: https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-10-pictures-do-not-sync

Try reverting to v9.3 to see if that fixes your problem.
 

davidlplume

New Member
Joined
Sep 8, 2020
Messages
4
Thank you clee01|, I have reverted to 9.3 and, sadly, it has not fixed the problem.

I have generated a LRSyncdiagnostic report but it is over 400Mb in size and I am unsure how to share this. I am reluctant to sign up to Dropbox pro.
 
Joined
Jun 20, 2009
Messages
17,852
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Thank you clee01|, I have reverted to 9.3 and, sadly, it has not fixed the problem.

I have generated a LRSyncdiagnostic report but it is over 400Mb in size and I am unsure how to share this. I am reluctant to sign up to Dropbox pro.
Please go back to the Bug report that I reverenced above and Ask Adobe how to submit the 400MB diagnostic for the issue.
 

davidlplume

New Member
Joined
Sep 8, 2020
Messages
4
Thank you clee01|. From the trail on the other report that you referenced it looks like the issue has been uncovered and a resolution is being investigated "Seems like there is a bug in 9.4 which is not clearing up the sync UI numbers. Sync is happening all fine but numbers are stuck. We are looking into this."

I am guessing that I will need to wait for 9.5 for the answer. Thanks for your help.
 
Joined
Feb 1, 2010
Messages
13,028
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
I am guessing that I will need to wait for 9.5 for the answer. Thanks for your help.
There won't be a 9.5, as the latest update was to version 10.0. I suggest you try that.
 
Joined
Nov 13, 2019
Messages
44
Location
Washington, DC USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Check to see if syncing is paused first. I'm not sure what causes this but I've noticed it happening occasionally.

If sync is running and you have items stuck in the sync queue, you can rebuild the sync database. If you hold down the option key while viewing the Lightroom Sync tab in Preferences, you will see an option to Rebulid Sync Data (which is following by a LR restart). This will often clear up problems in the queue.

Items can get stuck in the queue if you delete them in on either side of the sync (in Classic or in the Lightroom cloud app) while they are still in the queue. Probably not your problem but worth mentioning.
 

tim.young

New Member
Joined
Dec 30, 2020
Messages
1
Hi All, new to this Forum but not new to Lightroom. Just got back to it after a few years using other products. I am having a syncing issue as well. I have a total of 33,381 photos, all either Canon, or Sony RAW format, as well as a few Jpeg. At present only 910 are showing synced. In the Pref, Sync there are 131 files downloading with error "Unknown". I have tried rebuilding but still not fixing issue. I have a feeling that the 131 is blocking the other 32,340 from syncing. I am on Windows 10 and Lightroom classic 10.1. I really don't want to delete all synced data but if that is the only solution I will.
 

Attachments

  • Screenshot 2020-12-29 163825.png
    Screenshot 2020-12-29 163825.png
    21.4 KB · Views: 41
  • Screenshot 2020-12-29 163942.png
    Screenshot 2020-12-29 163942.png
    84.6 KB · Views: 38
Joined
Nov 13, 2019
Messages
44
Location
Washington, DC USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
A couple of thoughts:
  • The 131 downloading are from your mobile device (phone/tablet).
  • The 33,381 photos in All Photographs are likely not syncing because they are not in a synced collection.
  • To see the photos from LR Classic on your mobile devices add them to a collection (standard type, not smart collection) and then set the collection to Sync. That will create an album on your mobile device with previews of your photos. These photos can be edited and rated on all your devices and the changes will sync. Keywords do not sync.
  • If the 131 downloading do not finish syncing, verify that syncing is not paused (click the Cloud icon in the Module Picker). If syncing is running and the download doesn't finish, go to sync settings in Preferences, hold down the Alt key and click rebuild database. You don't lose any data -- the rebuild just rebuilds the sync list.
 

JHEverett

New Member
Joined
Jul 15, 2021
Messages
2
I also have 2 blank photos with no metadata, one of which is stuck in my sync queue - Is there a simple solution to this yet? - I know some people have sent their catalog in....... looking forward to any advice - Thanks
 
Joined
Nov 13, 2019
Messages
44
Location
Washington, DC USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Open Lightroom Preferences and click on the Lightroom Sync tab.

Hold down the Option (Mac) or Alt (Win) key and you will see a button to "Rebuild Sync Data". Click that and let it run which will include restarting Lightroom at the end.

That rebuild process resolves most issues.
 
Joined
Nov 13, 2019
Messages
44
Location
Washington, DC USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Thanks Alec - I've tried that but the "blank" photos still exist and they are still trying to Sync. Jo
Could you provide a screen shot of the Sync activity area at the bottom of the Lightroom Sync tab in Lightroom preferences? Would help to see the Sync type and Sync Details and Errors column values for the files in question.

For starters, with some errors, you can click on the value in Sync Details and Errors column, and get information about the error.

Would also help to know if your original was from your camera imported to Lightroom or from your camera or tablet and is being synced from the Adobe cloud.
Choose one of the files and click the link in Asset Path / Link. What do you see?

Do you see the image in Lightroom Classic? If so, is there any indication the file is missing?

Alternatively, does a browser open taking you to a webpage showing you the image in Lightroom Cloud?

Those are some paths to answering your mystery.

Alec
 
Top