• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The November 2019 Lightroom updates are now available. Lightroom Classic includes the ability to export the same photos as multiple sizes/formats in a single export, content aware fill for panorama edges and more. It does require a catalog format upgrade and there are updated system requirements, so you may want to wait a few days before upgrading.
    Lightroom (cloud-based service) has export options (such as TIFF format, renaming and color space), custom sort order on the desktop, copy/paste to multiple photos on iOS and more.
    The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Lightroom Classic - Crashing when Opening with Latest Catalog

dominic

New Member
Joined
Oct 9, 2019
Messages
4
Lightroom Version
8.4.1
Operating System
Windows 10
I began having a problem with Lightroom Classic a few days ago.

When I try and open it to attempts to load the latest Catalog, opens up the Library Module and you can see the photo thumbnails that are in the Catalog appear on screen. It includes the last ones I added to the Collection I was working with. The program then attempts to populate the Folders and Collections Lists on the left of the screen, but only gets so far before I get a Crash Report Screen appearing.

When I double click on an older backup version of the Catalog, Lightroom opens without any problem although there are around 2 weeks of work missing from the Catalog.

I am running the latest Version of Lightroom Classic (8.4.1) and have updated my Graphics Driver to the latest one.

I have no errors saying that my Catalog is corrupt.

The Catalog size that is failing to load is 829,360 kb and the one that loads is 581,652 kb.

Is it possible that the larger Catalog is corrupt, even though I have no message saying this?

If so, how do I recover it?

Any pointers would be appreciated.

Thanks
 

Jimmsp

Senior Member
Joined
Jan 9, 2011
Messages
1,004
Location
Green Valley, Arizona, USA
Lightroom Experience
Advanced
Lightroom Version
What changed on your system a few days ago? Did you by any chance install a new update to the Win 10 OS?
The last update a week or so ago has had some issues in the field.
What Win 10 version are you running now?
 

dominic

New Member
Joined
Oct 9, 2019
Messages
4
Jim
Thanks for getting back so quickly.
I have updated to Windows 10 1903 x64 (KB4524100) and I have a feeling that is perhaps part of the problem.
I cannot run Google Chrome (well it opens but it won't display on screen,) plus I had a few problems with some other programs a few days ago e.g. I could not copy and past using File Explorer although that now works.
The annoying thing is that some older catalogs will open properly, just not the one I need.
 

Jimmsp

Senior Member
Joined
Jan 9, 2011
Messages
1,004
Location
Green Valley, Arizona, USA
Lightroom Experience
Advanced
Lightroom Version
I don't have that KB number in my history. I have Win 10 Professional, v1903, and the last update I did was on 10/1, KB 4517211. And my Chrome has been a little funky at times as well.
I have put a delay on the latest on, KB4524147 because of some of the issues it has reportedly had. There were a couple of new updates released today which I will wait a few days on.

BTW - I always back up everything to external disks just before I do any Win 10 update, including the LR Catalog. I don't rely just on LR's backup.

But that doesn't help you in this case. You might contact Adobe support for help.
I would also try rolling back the last update that you did to Windows before you contact Adobe.
 
Joined
Sep 29, 2007
Messages
21,820
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
If you want to send me the catalog, I'll try to open it here to see if it opens ok. Zip up just the catalog (lrcat file) and use Dropbox or WeTransfer to send it to [email protected]
 

dominic

New Member
Joined
Oct 9, 2019
Messages
4
Thanks.

Seems like my Windows 10 update is later than the one you have (4517211) but prior to the 4254147 update.

The roll out of updates seems to be really random for some reason.

I have checked and according to Windows I have the latest one for my PC.

I'll send you the lrcat file by WeTransfer when I get a chance.

Regards.
 
Joined
Nov 5, 2017
Messages
408
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
I'll send you the lrcat file by WeTransfer when I get a chance.
Okay thanks for sending that through to us. We opened it fine. Obviously all photos are missing, but I just navigated various folders, seeing if I could invoke any error message or failures, and no issues at all with it.

Did you try trashing Preferences already? I appreciate you have other catalogs that open fine, but it's amazing what that can do. to do so, Hold Alt Shift while starting Lightroom.

Let us know and we'll think of some other things to try!
 

dominic

New Member
Joined
Oct 9, 2019
Messages
4
Hi Paul

Thanks for checking the integrity. I was able to do this myself yesterday as I was able to open Lightroom using an older Catalog and when I went to change to a new Catalog it asked if I wanted to test the integrity of it. I did this and it seemed to pass and attempt to open it, but with the same result of generating a crash report screen. I have also just tried your suggestion above with the same results.
Given that;

a) Windows loads very slowly.
b) Chrome will not open properly.
c) PC randomly crashes.
d) This Lightroom Catalog seems problematic (even the backup I have.)
e) Previous pages randomly load in Edge

I think the problem relates to the Windows 10 Upgrade (now there's a surprise.)

However, if you have any other potential things I could try, then I'm willing to have a go.

Thanks
 
Joined
Nov 5, 2017
Messages
408
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
Hi

Sounds like a Windows stye problem then by what you describe. I assume you've done all the usual things (disk defrag, check, RAM tests)

Check the Graphics Driver (although Windows loading slowly, not sounding so good)

Final piece of sage advice: make sure all your backups are up-to-date!
 
Top