Lightroom 6 crashing shortly after opening on macOS Big Sur.

EricS

New Member
Joined
Oct 25, 2017
Messages
5
Lightroom Experience
Intermediate
Lightroom Version
Lightroom Version
Lightroom 6.14
Operating System
  1. macOS 11.0 Big Sur
I have Lightroom 6 downloaded on my iMac, and it was working fine until after I updated to macOS Big Sur.
The application will load like normal but shortly after loading the catalog, maybe about 1 minute, it'll simply shutdown.
I tried testing the integrity of the catalog, and it still happened. Is there anything I can try?
 
Joined
Jul 2, 2015
Messages
10,717
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
I really don’t understand why people who want to continue to use ancient software still upgrade to the latest OS. It’s just a matter of time before something like this will happen. Did you really need Big Sur or even Catalina? Couldn’t you stick to a version of MacOS that is known to run Lightroom 6?
 
Joined
Jun 20, 2009
Messages
17,265
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
LR6 has not been supported since 2017. It has not been tested to run on the last several MacOS updates, None since High Sierra (v10.13) Your expectation that obsolete Lr6 will run on the latest Operating system is unrealistic.
 

LexS

Member
Joined
Feb 14, 2019
Messages
86
Lightroom Experience
Intermediate
Lightroom Version
6.x
HighSierra is the latest OS that will run 32bit apps. Although LR6 is 64bit, it does not have a 64bit installer, and is not tested in 64bit only OS.
 

michaelp

Member
Joined
Aug 14, 2019
Messages
36
HighSierra is the latest OS that will run 32bit apps. Although LR6 is 64bit, it does not have a 64bit installer, and is not tested in 64bit only OS.
Not correct. Mojave runs 32 apps just fine. It's from Catalina onwards that 32 bit apps will not run.
 

michaelp

Member
Joined
Aug 14, 2019
Messages
36
I have Lightroom 6 downloaded on my iMac, and it was working fine until after I updated to macOS Big Sur.
The application will load like normal but shortly after loading the catalog, maybe about 1 minute, it'll simply shutdown.
I tried testing the integrity of the catalog, and it still happened. Is there anything I can try?
Lr 6 is a 64 bit app but the associated Adobe license manager is 32 bit. For this reason you cannot install or activate Lr 6 on Catalina or Big Sur.

However, if Lr 6 is installed before you upgrade to Catalina, it will run, but usually just once. It is possible to keep it running if you kept a couple of license-related files and copy them over the ones that get updated. See here for details. If you did't keep the files you can find them in Time Machine (if you backed up!).

I believe the same will apply for Big Sur, but NOT on M1 Macs.

BTW It is possible (I have done this) to install Mojave on an external SSD, and then install Lr 6 on that. You boot to that drive (change startup disk in System Preferences), launch Lr (you may have to deactivate a previous installation, if you had two) and then open the catalog on the original drive (usually Macintosh HD). Worked seamlessly for me. See here.
 

LexS

Member
Joined
Feb 14, 2019
Messages
86
Lightroom Experience
Intermediate
Lightroom Version
6.x
Michael, you are quite right to correct my post: indeed I should have written Mojave, which is btw the OS on one of my machines and runs LTR6...
excuses, LEX
 
Top