• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.
  • It's Lightroom update time again! No new features in the mid-April release, but new cameras, lens profiles and bug fixes. Here's the usual list

Lightroom 6.14 to Macbook

BungyW

New Member
Joined
Nov 16, 2018
Messages
10
Lightroom Experience
Beginner
Lightroom Version
6.x
Lightroom Version
6.14
Operating System
macOS 10.14 Mojave
I have Lightroom 6.14 on my Mac and am looking to download a version onto my new MacBook Air
I have found a thread that explained that you first need to download the basic version and then download the V6.14 patch, does this mean I don't have to download the other 17 patches in between the initial and last version.
 
Joined
May 12, 2011
Messages
3,246
Location
Canada
Lightroom Experience
Advanced
Lightroom Version
does this mean I don't have to download the other 17 patches in between the initial and last version.
Yes, just 6.14.
 

BungyW

New Member
Joined
Nov 16, 2018
Messages
10
Lightroom Experience
Beginner
Lightroom Version
6.x
Many Thanks, thought I would have had to go through them individually.
 

GaryP

New Member
Joined
Dec 25, 2018
Messages
5
Lightroom Experience
Intermediate
Lightroom Version
4.x
No, you need just the basic version
 
Top