• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • We are delighted to announce that Single Sign On has just gone live, so you'll no longer have to remember multiple login details for this site. Most existing passwords have been carried over, but if your password doesn't work, you can reset it using the Lost My Password link. Your current forum username is Guest. You're welcome to choose your preferred username here.

Lightroom 3.6 and update my old Mac to Sierra/Mojave : bad idea ?

Pentaxforever

New Member
Joined
Nov 3, 2018
Messages
2
Lightroom Experience
Beginner
Lightroom Version
3.x
Lightroom Version
3.6
Operating System
Other (please note in thread)
Hi,
this is my first post, so nice to meet you :)
My name is Francesco and I live in Italy .
I work with a 9 Years old Mac with OSX 10.8 ( " Mountain Lion" ) and Lightroom 3.6.
My problem is: since one year I have trouble using my mac because I receive tons of warning that every software ( chrome, firefox, dropbox,google drive) are "too old" and can't be updated, because the IOS Version is too old.
Do you think that my Lightroom 3.6 will still work on Mojave ?
The option "update Lightroom" is difficult because the hardware is pretty old...
I need really the basic function of Lightroom and I use Lightroom once a month, I don't want to spend a fortune for a new Mac and a new Lightroom Version
Any suggestion?
Thank you for your answer!
 

Zenon

Senior Member
Joined
Jan 13, 2017
Messages
1,094
Lightroom Experience
Advanced
Lightroom Version
Classic 8
No. 3.6 won't work in Mojave. LR6 will work on Mojave. That is the last stand alone licence. Only thing is your system is too old update to Mojave. I'm pretty sure you can get the previous one - High Sierra but I'll have to verify for a 9 year old machine. LR 3.6 won't work on that either.
 
Last edited:

Paul McFarlane

Lightroom Queen Publishing
Staff member
Administrator
Moderator
Joined
Nov 5, 2017
Messages
93
Lightroom Experience
Power User
Lightroom Version
Classic 8
Hi Francesco and welcome!

To be honest, a 9 year old machine is going to trip up more and more with software that is written for the power and capabilities of today's hardware

You don't have to spend a fortune to get something that will simply make life easier with compatibility

I would humbly suggest it might just be the time to evaluate the options
 

Pentaxforever

New Member
Joined
Nov 3, 2018
Messages
2
Lightroom Experience
Beginner
Lightroom Version
3.x
Hi Zenon and Paul,
Thanks for your replies.
You convinced me, I'll evaluate an upgrade of both instruments: software and hardware.
Maybe not tomorrow, but soon :D, without spending time and money in workarounds.
Thanks!
 
Top