Library Cannot find my Images

Joined
Aug 12, 2018
Messages
2
Lightroom Experience
Intermediate
Lightroom Version
5.x
#1
Lightroom Version
7.5
Operating System
Windows 10
Hi all. Hope someone can assist. LR 5 is not finding my files; all I get is the file folders with a ? after each file. This is only on my 3 removable drives: the C drive in the PC is connecting to LR. LR is showing me the images but does not seem able to find them in Library. Appears to have gotten worse as I was switching (connecting) drives while I was searching for certain image files; LR only can find 3 files. The left panel can see and identify the 3 different drives but I am thinking it has mixed the E: and F: hard drives and cannot tell if the hard drive that is plugged in now (E: drive) is the same (E:) as it saw before . Very frustrating as I am unable to access years of images. Thanks.
 

JohanElzenga

Lightroom Guru
Staff member
Moderator
Lightroom Guru
Joined
Jul 2, 2015
Messages
7,666
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Classic 7
#2
What has probably happened is that Windows assigned a different drive letter to the removable drives. What you could do to solve it right now is check which drive Lightroom thinks should have the lowest letter, and then which drive the next, etc. Then turn off your computer, disconnect the drives and reboot. Then after your computer has started up, reconnect the drives one by one in the order they should have according to Lightroom. Alternatively, you would have to 'reconnect' the folders (see below).

For or more permanent solution you may want to assign a (higher) drive letter yourself, so that the drives will always have the same letter (How to assign permanent letters to drives in Windows). Then 'reconnect' the folders in Lightroom so Lightroom knows this new letter (Lightroom thinks my photos are missing—how do I fix it? | The Lightroom Queen).
 
Joined
Aug 12, 2018
Messages
2
Lightroom Experience
Intermediate
Lightroom Version
5.x
#3
I am attempting to follow the steps outlined in "Lightroom thinks my photos are missing-how do I fix it?" however there are several directions that assumes one knows how to go about the steps such as:
1. If missing a single folder, right click on the missing fold and select Find Missing Folder. OK, so that is done and a Find Missing Folder window appears with presumably a location of where the folder I am seeking is currently residing in the header bar. Instructions state to navigate to the new location of the folder and Lightroom updates. How do you navigate to the new location? Am I supposed to see my files in that new location? What will you see? What keystrokes do you need to do? What will be the location name, like will my 2015 photos now be listed under 2018 if that is where LR will update to? Also, I have seen a Merge question pop up but what file is this merging to? Thanks.
 

JohanElzenga

Lightroom Guru
Staff member
Moderator
Lightroom Guru
Joined
Jul 2, 2015
Messages
7,666
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Classic 7
#4
How do you navigate to the new location? Am I supposed to see my files in that new location? What will you see? What keystrokes do you need to do? What will be the location name, like will my 2015 photos now be listed under 2018 if that is where LR will update to? Also, I have seen a Merge question pop up but what file is this merging to? Thanks.
You do have to know the location, of course. The name is usually the same name as the missing folder, it's just in a different place than Lightroom thinks it is. In your case the only difference would be the drive letter, so Lightroom thinks the folder is something like D:/Parent folder/Subfolder/2015 and now it is E:/Parent folder/Subfolder/2015. The merge question should normally not come up in this case.

Maybe you should post some screenshots of your folder panel and the drives, so we can have a look.
 
Top