• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 21 May 2024 It's Lightroom update time again! See What’s New in Lightroom Classic 13.3, Mobile & Desktop (May 2024)? for all the update news, including Generative Remove using Firefly AI and more!

Latest PS corrupted external editing preset preset

Status
Not open for further replies.

jjlad

Active Member
Joined
Jan 18, 2009
Messages
613
Location
Winnipeg, Canada
Lightroom Experience
Advanced
Lightroom Version
Classic
Lightroom Version Number
12.1
Operating System
  1. Windows 10
Hi there,
I can't find the thread I had on this previously, but one of our GURUs had provided instruction on how to set up an editing preset to send a photo to Photoshop for editing as a JPEG so that when Ctrl-S was pressed it would save the file and it WOULD SHOW UP BACK IN LIGHTROOM.
I made that preset and it worked until one of the last two updates to PS ...not sure which one botched it up but one of them did.
Now when I select that preset it opens the one for Topaz Photo Ai.
I tried to change it by 'choosing' Photoshop by picking the Photoshop.exe from Programs.
After the last (about 5th) attempt:

1671672369378.png

it still does not work:
Here's the selection:
1671672447905.png


and this illustrates that what it wants to send the photo to is Topaz Photo Ai, instead of Photoshop.

1671672505333.png


If anyone knows how I can resolve this, please let me know.
Thanks in advance.
 

Attachments

  • 1671671890802.png
    1671671890802.png
    36.3 KB · Views: 70
Just to clarify
Here's where I change the somehow changed program selection to Photoshop:
1671672928553.png

and of course I click Use Anyway

No matter how many times I try to resolve this, it just won't work.
 
After you use the "Use Anyway" option after changing the preset, are you then saving the changed preset again (click back in the Preset box and use "Update preset Photoshop JPEG 300dpi"). I've just set that up on my Mac system and it works correctly, so should work on Windows as well.
 
I don't see that option anywhere Jim. All I have is the "Restart LR Classic" and "OK" buttons. I click "OK"
1671718144410.png
and that takes me out of that and back to LR in whatever view I was in before I clicked on Edit/Preferences/External Editors...
and before I click that it shows the preset was edited in its title just as it did before that:
1671718215269.png
 
I know it's weird, but you need to click on the Preset line again to get an option to save:
2022-12-22 10_50_45-Latest PS corrupted external editing preset preset _ Lightroom Queen Forum...png
 
After you use the "Use Anyway" option after changing the preset, are you then saving the changed preset again (click back in the Preset box and use "Update preset Photoshop JPEG 300dpi"). I've just set that up on my Mac system and it works correctly, so should work on Windows as well.
Thank you Jim, and Hal! That did it after I clicked on that, then selected 'Update preset'
1671923826401.png

Season's best!
 
Back to square one again. Now no matter how many times I "update" that preset, it does not work. Hitting Ctrl-S in Photoshop (after flattening the image) results in a .tif file every time.
It's like every time they update the program that functionality is lost even though the preset is there and has not been changed. I even tried changing the DPI then saving it and trying it and that didn't work either. So now, it just doesn't work at all.
What the heck is Adobe's refusal to have that option automatically available, based on? Every other editing program I've acquired or tried, has the ability to edit in their programs and return the file to Lightroom automatically ...in whatever format was chosen.
To have to go back to Lightroom to determine the file location, then backtrack through folders and drives to get there in the Photoshop Save As or Save a Copy dialog and then have to Syncronize that folder in LR to get the image into the catalog ...is totally ABSURD! I
t's like they are thumbing their noses at you and saying "Squirm peasant, we like to make more work for you".
 
Thank you Jim, and Hal! That did it after I clicked on that, then selected 'Update preset'
View attachment 20022
Season's best!
The dialog you should get when you invoke the secondary editor is a little different than the one you'll get with the main editor. At the bottom (not shown in your screenshot) are some extra settings that can override your preset. I think that is what's happening. Those settings may not be expanded, so you did not notice them:

1 2023-01-23 11-12-54.jpg
 
Just read this thread and tested my [Edit in Ps as JPG] Preset and like @jjlad it no longer works for me.
(I possibly have not used it since LrC v11).
I redefined the Preset and tried again- it just creates a JPG but will not open in Ps.
2023-01-24 07_38_44-Preferences.jpg


A work-around would be to use the Export dialog with [Add to Catalog] and Photoshop in the 'Post Processing' panel. But saving the file from Ps is a little more complicated- [Ctrl+W] to close > Change filetype to JPG > Yes to Overwrite.
2023-01-24 07_44_07-Lightroom Catalog-v12 - Adobe Photoshop Lightroom Classic - Library.jpg

Following this thread with interest.
 
This is an interesting thread. I rarely export a jpeg to PS from LR and if I did I would probably just export it full size and quality to my desktop and then open it in PS in the normal way and do whatever I wanted with it editing-wise and them save it in PS for however I wanted to use it. Or just reimport it to LR if for some reason I wanted a jpeg back there (which I probably never would since I have the raw in there).
But all of that aside, this is an interesting thread and shows that the gurus really get on it!.
 
Just read this thread and tested my [Edit in Ps as JPG] Preset and like @jjlad it no longer works for me.
(I possibly have not used it since LrC v11).
I redefined the Preset and tried again- it just creates a JPG but will not open in Ps.
View attachment 20226

A work-around would be to use the Export dialog with [Add to Catalog] and Photoshop in the 'Post Processing' panel. But saving the file from Ps is a little more complicated- [Ctrl+W] to close > Change filetype to JPG > Yes to Overwrite.
View attachment 20227
Following this thread with interest.
Interesting. On my Mac I can open the file as a jpeg in Photoshop beta just fine and it saves back just fine too. Maybe this is a Windows thing.
 
Interesting. On my Mac I can open the file as a jpeg in Photoshop beta just fine and it saves back just fine too. Maybe this is a Windows thing.
Exactly what I was just going to say. Works on Mac, will try to test on Windows.
 
Exactly what I was just going to say. Works on Mac, will try to test on Windows.

Works OK on Windows too.

But just to be clear, I'm testing using raw files (proprietary and DNG). Is that the case with others? I'm surprised, Rob, that you see the jpeg created in LrC before PS even opens....that shouldn't be the case, the jpeg should open directly into PS (in the system cache) and shouldn't be created on disk until it is saved in PS. Maybe I'm missing something in the way you are trying to work, that might be relevant.
 
So on my desktop system LrC v12.1 Windows-11 (previous test on a Dell laptop 12.1 W10), I still do not get any action from Photoshop with my [Edit in Ps as JPG] preset, as I once did before. And thinking there might be a relationship with all the posts in the Adobe Community about DXO, Luminar, etc, "not returning an image to LrC".
I re-wrote the External Editor settings to be sure it was selecting Ps 2023 and my result in screen-clips:
1) My selected NEF image of the Patti-cakes:
2023-01-25 02_30_08-Roberts Catalog-v12 - Adobe Photoshop Lightroom Classic - Library.jpg

2) The dialog that the Preset throws open-
2023-01-25 02_32_47-Roberts Catalog-v12 - Adobe Photoshop Lightroom Classic - Library.jpg

3) [Edit a Copy with Lightroom Adjustments], and I now see this- The new {..._Edit.JPG}
2023-01-25 02_33_16-Roberts Catalog-v12 - Adobe Photoshop Lightroom Classic - Library.jpg

4) Photoshop does not open- nada, not a peep!. Just the new JPG file in the library.
I am not a regular user of this External Editor function Ps>JPG, but have followed and tested for my own interest and knowledge.
 
Thanks for the 'Group Effort' here folks!
I simply wish Editing in Photoshop would offer the same dialog and same returns as does all the other modern Plugins.

Topaz Photo Ai, Topaz Sharpen Ai, Topaz Denoise Ai, Topaz Gigapixel Ai, Luminar Ai and Luminar Neo all offer a choice of what you want back, then LR creates that file before sending it to those programs and it updates after editing with them. You have the edited file on disk and its presence in LR.

Photoshop seems to be the only editing program that doesn't have an honest working relationship with Lightroom, and is the only one where the programs are supposed to be a 'family of products'. In this regard they aren't even kissin' cousins.

To make matters worse, after editing in Photoshop you have to Save As or Save a Copy and that opens a dialog showing the save directory as the last one you saved to ...which may be USB adapters and drives and levels of folders and sub folders away from where the file was when the process started. It's literally a Plumbers Nightmare and Photoshop never seems to know where it got the file from.

In total contrast to this ...virtually all the other editing programs that plug into Lightroom ...completely simplify this, by automatically updating the jpeg or tiff or whatever Lightroom created and reflecting the changes in Lightroom. DONE.

I question why Lightroom/Photoshop seem incapable of doing what the other vendors do? To me this just makes no sense. Lightroom is great for what it does and Photoshop is great for what it does. For me however I've never felt they were truly 'working together' due to this plumbing issue. Sure ...you can hit save and have a Tiff file created, saved in the correct folder and returned to LR. That file will be 10 times the size of the jpeg started from and to save space ...I have to export the tiff to jpg then delete the tiff. It's especially frustrating when the jpeg one starts with is a small scanned image.

I wish Adobe would look at this from that perspective and fix the program instead of having people spend countless hours mucking around to try and find workarounds.

Thanks again guys, for your patience and testing. If any of you are 'connected' to Adobe in any way, I hope you can relate to this and RELAY it to Adobe. I tried a few times …unsuccessfully. That was before these other vendors had their user friendly systems available though, so hopefully that could embarrass Adobe into making Photoshop integrate as seamlessly with Lightroom as the others have.
 
jjlad,
I know you have had problems making what you are trying to do here all come together within your workflow and it must be very frustrating but leaping to the strong conclusion that PS & LR don't work well together is not fair in my opinion and that has not been my experience. I've been using PS for for 25 years now and LR for a long time, and they work together fine for what I do. I've never had trouble going back and forth between PS and LR and I've done a lot of focus stacking, HDR and thousands of TIF scans where I was back and forth a lot in both programs. You have a lot of presets and multiple routes to various drives, and mine is far more streamlined to one big internal SSD data drive, so our experiences are different in that regard. Once you are out there in file and connection land, other problems can creep in that go beyond Adobe....
Don't give up yet. There are a lot of photographers out there using LR and PS in a fairly happy marriage.
Sorry you had all of that frustration.
 
jjlad,
I know you have had problems making what you are trying to do here all come together within your workflow and it must be very frustrating but leaping to the strong conclusion that PS & LR don't work well together is not fair in my opinion and that has not been my experience. I've been using PS for for 25 years now and LR for a long time, and they work together fine for what I do. I've never had trouble going back and forth between PS and LR and I've done a lot of focus stacking, HDR and thousands of TIF scans where I was back and forth a lot in both programs. You have a lot of presets and multiple routes to various drives, and mine is far more streamlined to one big internal SSD data drive, so our experiences are different in that regard. Once you are out there in file and connection land, other problems can creep in that go beyond Adobe....
Don't give up yet. There are a lot of photographers out there using LR and PS in a fairly happy marriage.
Sorry you had all of that frustration.
Thanks for responding. I do hear you, but I work with 8 drives.
The fact that Photoshop DOES know where a file came from if you allow it to save as a tif file, but doesn't know where it came from if you invoke the Save or Save a Copy dialogs ...is just an insult to users. There is no excuse for that nonsense. That is NOT working well together. It has been a problem since Lightroom was launched. I've pointed it out for years but Adobe has been too stubborn to look at it. Do the programmers forget where they live if they go out their doors without an Adobe hat on?
 
Status
Not open for further replies.
Back
Top